On Monday September 25th from 10PM EDT - 12AM EDT (2AM UTC - 4AM UTC on September 26th), we will be performing system maintenance on the Firefox Accounts databases for two hours. During the maintenance window, there will be brief periods of a few minutes where users will not be able to login to their accounts. Please try again at a later time.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 96.03 on Mac Monterey doesn't display Cyrillic fonts correctly

  • 5 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by gevangasteren

When visiting sites such as the Russian Wikipedia, characters that are in the Cyrillic Times New Roman font display as blocks (shown in image). Safari does not have this problem.

When visiting sites such as the Russian Wikipedia, characters that are in the Cyrillic Times New Roman font display as blocks (shown in image). Safari does not have this problem.
Attached screenshots

All Replies (5)

Don't know what happened to the image, here is a imgur link that shows it non-corrupted. https://i.imgur.com/vyifY0u.png

[v56+] Type about:preferences#general<enter> in the address box. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

  • We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that

you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

  • If you use uBlock Origin make sure not to "block remote fonts".

Allow websites to use their own fonts is already checked, also on uBlock. No high contrast theme either. It's weird because Safari displays the page correctly, but not Firefox. Using inspect element it seems that the specific font it's having trouble with is Georgia Bold.

Try this; remove Georgia Bold. Then try the site again. (Sorry, I don't know how.)

Same situation here. (I have uBlock set up correctly, also Firefox’s setting for letting web pages choose their own fonts.)

I found a web page using Roboto but that displays Cyrillic text correctly: https://www.ranker.com/list/famous-poets-from-ukraine/reference

After changing the Wikipedia theme to either Monobook or Timeless, the Cyrillic title displays properly, even though the Timeless theme uses the same Linux Libertine font as the problematic themes Vector legacy 2010, Vector 2022, and MinervaNeue.

There does seem to be something fishy about Firefox’s handling of this Linux Libertine, though. Do you know Font Ninja? It’s an add-on that shows you which fonts are used on the current web page. Now check out the screenshot of the Wikipedia Preferences page, where the text "Preferences" displays properly, but the sample text under the heading "Linux Libertine" in the Font Ninja window is shown in a sans-serif font. Also note the text there: "This is a system font", which is clearly not talking about Linux Libertine!

I add in the analogous screenshot from Russian Wikipedia (using the same Wikpedia theme) just to show what happens to Cyrillic text there.

My theory is that Firefox is replacing Linux Libertine by another font, some ancient fall-back system font that doesn’t include Cyrillic characters. But it does that only in certain cases, as evidenced by the correct display of different Wikipedia themes that use the very same Linux Libertine font. My guess is that, maybe, the problematic themes apply a certain style, like "Semi-Bold", which triggers this behavior, but I don’t know how to check that.

Hope this helps to pinpoint the problem – and solve it ;-)