Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is asking to update but I don't want to. How to stop updates

  • 6 பதிலளிப்புகள்
  • 44 இந்த பிரச்னைகள் உள்ளது
  • 488 views
  • Last reply by BlueBeard1963

I don't want to update my firefox because newer versions don't allow a whole bunch of very useful (to me) add ons. However, Firefox has begun asking me to update each time i open the browser. How do I stop it asking and how do I prevent it upgrading. Oh and if it does upgrade anyway (i've heard this can happen) how do i roll it back. Thanks in advance.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select Update. Check the settings.

Also turn off Use a background service to install updates

Read this answer in context 👍 3

All Replies (6)

I thought Firefox never forces updates. But you can alter this decision and make sure it's set to disable by doing so:

Paste "about:preferences#advanced" into your URL bar search Click to update and alter as needed.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select Update. Check the settings.

Also turn off Use a background service to install updates

I have used the chosen reply several times, but it still updates without asking for permission. FF 56.02 does not show an advanced option, but goes straight to general tab under tools / options (same thing). Update selection is set to never check for updates, and use background service is turned off. I re-install FF 54 each time FF updates, reason being my favourite addons do not work in FF55 on.

I have found a work around for this problem. I get notifications from Firefox and also Kaspersky that updates are being downloaded. When this happens I disconnect the modem, wait a bit and reconnect. I then get a message stating unable to install updates and gives the option of not skipping this update (this time only). This saves the problem of re-installing an earlier version of Firefox. Not sure if this only works because I have Kaspersky anti virus.

teapot2 said

I have found a work around for this problem. I get notifications from Firefox and also Kaspersky that updates are being downloaded. When this happens I disconnect the modem, wait a bit and reconnect. I then get a message stating unable to install updates and gives the option of not skipping this update (this time only). This saves the problem of re-installing an earlier version of Firefox. Not sure if this only works because I have Kaspersky anti virus.

That does sound like a message from Kaspersky - not from Firefox, which "doesn't like being told NO" and wouldn't offer that type of option once the download commences.

The preferences/disable updates doesn't work. Firefox will update the versions no matter what. What you have to do is let the update run to the latest vers, then go into the firefox directory and delete everything, leaving the empty directory. Then install the vers that you want into that directory. Then make sure you have the updates disabled.

Why Firefox would force the updates is beyond me, they are as back as Microsoft with forcing the update from Win-7 to Win-10.