cancel
Showing results for 
Search instead for 
Did you mean: 

why cant i use 3.6 still i like this verison

Highlighted
New Contributor

why cant i use 3.6 still i like this verison

cmon firefox i like this verison i dont want to upgrade Smiley Sad(( this best version ever made for font to, i dont like 4 and up..... i cant see why we cant keep browser for years.

5 REPLIES
Support Forum Moderator

Re: why cant i use 3.6 still i like this verison

Mozilla doesn't stop you from using an older version of Firefox, I am still using Firefox 2.0.0.20 for part of each day.

New Contributor

Re: why cant i use 3.6 still i like this verison

Ok flash though when i update says something? i think im using flash 10. I just prefer the layout of 3.6 to 14 is all.

Site Moderator

Re: why cant i use 3.6 still i like this verison

I'm curious why you use the older Firefox 3.6.13 version and not the most recent Firefox 3.6.28 version.

Note that the Flash requirements for Flash versions later than 11 state that a Firefox 4+ version is required. For Firefox 3.6 you get Flash 10.3 offered if you try to download Flash.

You won't be able to use HTML5 features with the Fx 3.6 version and benefit from other CSS enhancements. Also all JavaScript may not work in your Firefox version and you may see a notification on web pages that you are using an older and unsupported browser.

New Contributor

Re: why cant i use 3.6 still i like this verison

HTML5??? mmmm Guess it seems i need to upgrade, many extentions dont work though too.

Site Moderator

Re: why cant i use 3.6 still i like this verison

There are a lot of new replacements under a different name for extensions that stopped working in Firefox 4+.
Themes always need an update.

Which extensions do you know that stop working?

Is It Compatible?:

Add-on Compatibility Center: