cancel
Showing results for 
Search instead for 
Did you mean: 

why I couldn't browse some particular wiki page, for example http://wiki.openwrt.org/toh/start it's blank.I have already use the vpn. Also it's fine in chrome.

Highlighted
New Contributor

why I couldn't browse some particular wiki page, for example http://wiki.openwrt.org/toh/start it's blank.I have already use the vpn. Also it's fine in chrome.

why my firefox couldn't browse some particular wiki page, for example http://wiki.openwrt.org/toh/start it's blank.I have already use the vpn(I'm chinese user). Also it's fine in chrome. I'm using firefox 18.0.1,Kubuntu.

3 REPLIES
Site Moderator

Re: why I couldn't browse some particular wiki page, for example http://wiki.openwrt.org/toh/start it's blank.I have already use the vpn. Also it's fine in chrome.

Does Firefox retrieve any data from the server if you check the net log in the Web Console (Web Developer > Web Console;Ctrl+Shift+K)?

You need to do a hard refresh (Ctrl+F5) after opening the web console.

New Contributor

Re: why I couldn't browse some particular wiki page, for example http://wiki.openwrt.org/toh/start it's blank.I have already use the vpn. Also it's fine in chrome.

Oh,I see. It tells me that [01:40:06.875] HTML 文档的字符编码未声明。如果该文件包含 US-ASCII 范围之外的字符,该文件将在某些浏览浏览器配置中呈现为乱码。页面的字符编码必须在文档或传输协议层声明。 @ http://wiki.openwrt.org/toh/start

Site Moderator

Re: why I couldn't browse some particular wiki page, for example http://wiki.openwrt.org/toh/start it's blank.I have already use the vpn. Also it's fine in chrome.

This error message usually doesn't pose a problem.
The server does send a content type via the response headers: text/html; charset=utf-8 That file (wiki.openwrt.org/toh/start) also specifies UTF-8 encoding via the meta tag.

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

I don't know what Firefox actually receives in your case.
You can check this response header in the net log of the web console and click this entry.

GET http://wiki.openwrt.org/toh/start [HTTP/1.1 200 OK 236ms]