cancel
Showing results for 
Search instead for 
Did you mean: 

when I visit this site https://eopf.usps.gov/eOPF/jsp/essLogin.jsp it will ask me to update safari browser. I am using the current version of FF on a macbook.

Highlighted
New Contributor

when I visit this site https://eopf.usps.gov/eOPF/jsp/essLogin.jsp it will ask me to update safari browser. I am using the current version of FF on a macbook.

using ff 18.0.1 on a mac book pro. When visiting this site https://eopf.usps.gov/eOPF/jsp/essLogin.jsp it tells me to use Safari 2.0.4 or higher.

6 REPLIES
All Star Contributor

Re: when I visit this site https://eopf.usps.gov/eOPF/jsp/essLogin.jsp it will ask me to update safari browser. I am using the current version of FF on a macbook.

They are out of date. Safari versions have gone past that version long ago. What happens if you use Safari from Mac OS?

What happens if you use a fake Safari user-agent thru the extension User Agent Switcher?

New Contributor

Re: when I visit this site https://eopf.usps.gov/eOPF/jsp/essLogin.jsp it will ask me to update safari browser. I am using the current version of FF on a macbook.

"What happens if you use a fake Safari user-agent thru the extension User Agent Switcher? " not sure where that is in FF.

With Safari site works fine.

Ok found the user agent switcher add on. Tried it using IE but it now says I need javascript enabled.

2013-01-22-17-24-09-c3a12c.png
All Star Contributor

Re: when I visit this site https://eopf.usps.gov/eOPF/jsp/essLogin.jsp it will ask me to update safari browser. I am using the current version of FF on a macbook.

Why not download and import a list of user agents available for User Agent Switcher and use a fake Safari user-agent? That way, you will not be asked for Active X. There is a large list of such user-agents available from a link in the extension's Edit User Agents window. Download the list and import it.

New Contributor

Re: when I visit this site https://eopf.usps.gov/eOPF/jsp/essLogin.jsp it will ask me to update safari browser. I am using the current version of FF on a macbook.

OK so downloaded and imported the list but no luck. Doesnt work using the Opera browser either. I am trying to use FF for everything but not going to be able to I suppose.

Site Moderator

Re: when I visit this site https://eopf.usps.gov/eOPF/jsp/essLogin.jsp it will ask me to update safari browser. I am using the current version of FF on a macbook.

Try to create this String pref to override the user agent (no extension required) and see if the site works.

Name:

general.useragent.override.eopf.usps.gov

Value:

.*#Mozilla 5.0 (Macintosh; U; Intel Mac OS X 10_8; en-us) AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10

Close and restart Firefox

I had that Safari user agent (probably outdated) in my docs, but I do get the login form on Linux.

You can open the Web Console (Web Developer > Web Console;Cmd+Shift+K) with the page on display and enter this debug code on the command line and press enter:

displayMacProperties();

If you have the general.useragent.override pref set then reset this pref to the default value to remove it.

New Contributor

Re: when I visit this site https://eopf.usps.gov/eOPF/jsp/essLogin.jsp it will ask me to update safari browser. I am using the current version of FF on a macbook.

cor-el it worked!!! Thank You.

But after several visits I now get a missing plug ins window.

2013-01-27-06-46-28-0f848c.png