cancel
Showing results for 
Search instead for 
Did you mean: 

what level software on an imac is now supported by firefox

SOLVED
Highlighted
New User

what level software on an imac is now supported by firefox

We have an IMAC withthe OSX level software, and was just told by Firefox that our IMAC was no longer supported. We still have access to the internet, etc, but all other coverages are not there (security, spam, etc). If we update our present software, what level would we need to go to, in order for Firefox to work properly? Thank you.

1 ACCEPTED SOLUTION

Accepted Solutions
Site Moderator

Re: what level software on an imac is now supported by firefox

newer firefox versions require at least mac osx 10.6: www.mozilla.org/en-US/firefox/17.0/system-requirements/

1 REPLY
Site Moderator

Re: what level software on an imac is now supported by firefox

newer firefox versions require at least mac osx 10.6: www.mozilla.org/en-US/firefox/17.0/system-requirements/