cancel
Showing results for 
Search instead for 
Did you mean: 

vimeo video won't show

Highlighted
New Contributor

vimeo video won't show

Firefox 11, embedded vimeo video, doesn't show up on the screen, doesn't play.

11 REPLIES
Site Moderator

Re: vimeo video won't show

Does that happen with all videos on the Vimeo site?

It is possible that the video is encoded as H.264 and may not work if that is the case.

New Contributor

Re: vimeo video won't show

I can watch videos at the Vimeo site. Thanks for suggesting that; I hadn't checked.

So are you saying that FF cannot play videos with certain encodings (I'm not technical, don't know the difference), while other browsers can? Is there a plugin or add-on I can install to fix that incompatibility?

Strange, though. I just went back to the 2 websites I was having vimeo problems with yesterday. Those videos ARE now showing & working in FF. Hmm. Any guesswork explanation for this?

Thanks for your help.

Site Moderator

Re: vimeo video won't show

Was that a problem with embedding a Vimeo video on another web page (domain) or with viewing a video on the Vimeo site?

It may have been a problem with the Vimeo site or with the link on the page if it happened on another website and may have been corrected or there may have been a problem with the cache or cookies.

If it happens again then try to reload the web page and bypass the cache and possibly delete cookies from domains that are involved.

To bypass the cache:

  • Press and hold Shift and left-click the Reload button .
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"
New Contributor

Re: vimeo video won't show

It was a viewing problem. It wasn't a problem with the site or link or video, because I was able to view it in Chrome on this same computer. I did try reloading the page, as well as closing the browser and reloading. No help. I didn't think to delete the cache or cookies though.

Thanks for the bypass-cache methods. Those will prove useful from time to time, I'm sure. And thanks again for your help.

New Contributor

Re: vimeo video won't show

Above (cache/cookies) methods don't work for me. Can't play embedded videos on Vimeo and RT.com anymore. With the earlier FF version I had to switch Plugin container off in order to play Real files. What will it be this time?  :-(

Site Moderator

Re: vimeo video won't show

Which Flash player do you have installed?

New Contributor

Re: vimeo video won't show

Thanks Cor-el Have 11.1.102.63 installed. Btw, there's no problem with playing the RT files (Mp4 and Flv) as they appear in the source. A discrepancy between Rt's (and Vimeo's) config and FF11, I suppose.

New Contributor

Re: vimeo video won't show

Downgrading to FF10 solved the problem with RT.

New Contributor

Re: vimeo video won't show

My config in FF 10/11:

dom.ipc.plugins.enabled.nptest.dll;false
dom.ipc.plugins.enabled.npswf32.dll;false
dom.ipc.plugins.enabled.npqtplugin.dll;false
dom.ipc.plugins.enabled.npctrl.dll;false
dom.ipc.plugins.enabled.i386.nppl3260.dll;false
dom.ipc.plugins.enabled;false

If 'dom.ipc.plugins.enabled;true' Vimeo works fine, but RealPlay does not.
No probs using MSIE.
Has anybody any suggestions, please?

Problem solved
120411 added: dom.ipc.plugins.enabled.nppl3260.dll;false
changed: dom.ipc.plugins.enabled;true
and now Vimeo and RT videos are both working.