cancel
Showing results for 
Search instead for 
Did you mean: 

tabs are slow/unable to load a new url

Highlighted
New Contributor

tabs are slow/unable to load a new url

When I click a link, a new tab opens, but won't load the web page until I reload the tab.

This doesn't usually happen if I go to a recently visited site, but mainly on sites that I haven't visited in several hours.

My PC stays on between attempts and I keep FF open; rebooting doesn't help either.

This has been occurring since my last 2-3 FF updates.

6 REPLIES
Site Moderator

Re: tabs are slow/unable to load a new url

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
New Contributor

Re: tabs are slow/unable to load a new url

Nope--the problem's still there, even in safe mode.

Site Moderator

Re: tabs are slow/unable to load a new url

Do you have any cleanup or security software that might have corrupted the Firefox disk cache?

You can try to clear the cache.

New Contributor

Re: tabs are slow/unable to load a new url

Cleared the cache again (emptied it 2 days ago, too....no improvement, no change.

Site Moderator

Re: tabs are slow/unable to load a new url

You can create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

You can also try to reset Firefox:

New Contributor

Re: tabs are slow/unable to load a new url

I'm thinking this started because of a snafu when FF updated---is there a way to reinstall FF to go back to FF8 or so without losing my settings, etc? The problem appeared around about the time I went to FF9 or 10 or so. Reinstalling 16.0.2 didn't help.