cancel
Showing results for 
Search instead for 
Did you mean: 

"Couldn't load XRE functions" when starting FF 18.0, Linux.

Highlighted
New User

"Couldn't load XRE functions" when starting FF 18.0, Linux.

just installed FF 18.0 on Linux (Centos 5.8) where 17.0.1 has been running fine.

I always install in a local (to my login) directory, and have a desktop launcher to start it. I download each .tar.bz2 FF package to a subdir, where I unpack it, overwriting whatever was already in the firefox directory in that location.

doing that, I get the error above. so I renamed the directory and did a fresh extraction into the firefox directory that tar creates when unpacking the archive. SAME PROBLEM.

moving that directory aside and re-extracting the 17.0.1 archive yields a working Firefox.

What can I do to solve this problem?

the troubleshooting info below came from FF 17.0.1, since FF18.0 doesn't work.

6 REPLIES
Site Moderator

Re: "Couldn't load XRE functions" when starting FF 18.0, Linux.

It is always best to create a new directory and extract the content from the tar.bz2 archive to that directory instead of doing this in a directory that already has a Firefox installation or you can delete all the files in it.

New User

Re: "Couldn't load XRE functions" when starting FF 18.0, Linux.

as you can see in my posting, I also did that. No change.

Site Moderator

Re: "Couldn't load XRE functions" when starting FF 18.0, Linux.

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

New User

Re: "Couldn't load XRE functions" when starting FF 18.0, Linux.

It seems firefox 18 requires glibc 2.11 which centos 5 does not have. So I upgraded to 17.0.2 esr.

Site Moderator

Re: "Couldn't load XRE functions" when starting FF 18.0, Linux.

Weird:

The system requirements for Firefox 17.0.1 show: GLib 2.22 or higher

The system requirements for Firefox 17.0.2 (esr) and Firefox 16.0.2 show: GLib 2.12 or higher

New User

Re: "Couldn't load XRE functions" when starting FF 18.0, Linux.

these pages say "glib". which is NOT the same as glibc, which an earlier poster in this series said required a later version than I have. Was that earlier poster mistaken, perhaps, should have said "glib" ??

and when it says "glib", does that mean the package(s) that red hat/centos name "glib2-2.*.rpm" ??