cancel
Showing results for 
Search instead for 
Did you mean: 

need older update: for mac tiger 10.4.11 (have 3.030

SOLVED
Highlighted
New User

need older update: for mac tiger 10.4.11 (have 3.030

I have an older MAC laptop: can not afford a new one. I am running Tiger 10.4.11. My firefox is 3.0.10 which will not work anymore. The updates are too advanced. Where can I get a download of firefox for MY OLD computer that will work?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
SUMO Contributor

Re: need older update: for mac tiger 10.4.11 (have 3.030

Firefox 3.6.x branch is the last version available for Tiger, download Firefox 3.6.25. See ftp://ftp.mozilla.org/pub/firefox/releases/3.6.25/mac/ (pick your lang)

4 REPLIES
SUMO Contributor

Re: need older update: for mac tiger 10.4.11 (have 3.030

Firefox 3.6.x branch is the last version available for Tiger, download Firefox 3.6.25. See ftp://ftp.mozilla.org/pub/firefox/releases/3.6.25/mac/ (pick your lang)

New User

Re: need older update: for mac tiger 10.4.11 (have 3.030

Thank you for your suggestion. I got many windows that tell me this: 1. Firefox 3.6.25dmg is on a FTP server that may not allow applications to run or they will run very slowly. 2. Server connect interrupted, ftp.mozilla.org-2 3. following disk image failed to mount. Reason: not recognized.

Boy, I must be a geek, I can not even do this right.

Any other suggestions?

Thanks for your time!

New User

Re: need older update: for mac tiger 10.4.11 (have 3.030

I tried it many times and the last time I got to the download "ball" I push onto envelope. It says it can not complete because items are missing (error code: -43)

Almost there! What do you think is missing? Where would I find it?

Thank you for your knowledge and help!

New User

Re: need older update: for mac tiger 10.4.11 (have 3.030

To: Oxylatium!

I DID IT! I guess I am not that much of a moron chic as I thought! ha!

It works great! Many thanks!

Daryn