cancel
Showing results for 
Search instead for 
Did you mean: 

keep getting Mozilla Firefox (not responding) arrow takes 40 sec. to move same with scrolling....tried safe mode...still not working

SOLVED
Highlighted
Grand Master Contributor

keep getting Mozilla Firefox (not responding) arrow takes 40 sec. to move same with scrolling....tried safe mode...still not working

zzxc suggested safe mode....tried it but still get the same not responding and SLOW arrow commands...loading circle showing before moving arrow.

This happened

Every time Firefox opened

== a week or so

1 ACCEPTED SOLUTION

Accepted Solutions
New Contributor

Re: keep getting Mozilla Firefox (not responding) arrow takes 40 sec. to move same with scrolling....tried safe mode...still not working

Does this happen when you open up Firefox or when you go to specific websites? Also do you know if you have enough RAM? You can click Control(Ctrl), Shift and Escape(esc) at the same time and click performance when the new window opens up. If the bottom bar is low that means you do not have enough RAM to run Firefox properly.

20 REPLIES
New Contributor

Re: keep getting Mozilla Firefox (not responding) arrow takes 40 sec. to move same with scrolling....tried safe mode...still not working

Does this happen when you open up Firefox or when you go to specific websites? Also do you know if you have enough RAM? You can click Control(Ctrl), Shift and Escape(esc) at the same time and click performance when the new window opens up. If the bottom bar is low that means you do not have enough RAM to run Firefox properly.

Grand Master Contributor

Re: keep getting Mozilla Firefox (not responding) arrow takes 40 sec. to move same with scrolling....tried safe mode...still not working

I have the same problems. It takes forever to start up. This started occurring this last week. I usually just open Safari instead, which loads very quick. About 30 seconds later Firefox opens. I like firefox, but I will switch if this isn't fixed. I'm actually starting to like Safari.

BTW, I have a fast computer with a lot of RAM. Everything else on my computer is very snappy.

New Contributor

Re: keep getting Mozilla Firefox (not responding) arrow takes 40 sec. to move same with scrolling....tried safe mode...still not working

This happens every time I use Firefox. It doesn't matter what website I use. This is ridiculous!!!! There are a lot of people with this problem. I also disabled all the add ons which was useless. Which brings a new question. I have multiple versions of Java installed. How do I get rid of all but the most recent when the uninstall buttons are greyed out?

New Contributor

Re: keep getting Mozilla Firefox (not responding) arrow takes 40 sec. to move same with scrolling....tried safe mode...still not working

I HAD the same problem after I got rid of the Google redirect bug. I disabled the add-ons and everything is back to normal. Try downlaoding Hitman Pro 3.5 to find any other problems you have.

New Contributor

Re: keep getting Mozilla Firefox (not responding) arrow takes 40 sec. to move same with scrolling....tried safe mode...still not working

I have the same problem. Very slow startup of FireFox on a 6 month old computer with at least 35% unused memory. Sometimes Firefox does not start at all, just adds another instance to the Task Manager process list. Rebooting the computer solves the problem - but is a step backwards to move ahead. Not experiencing this problem with other applications.

New Contributor

Re: keep getting Mozilla Firefox (not responding) arrow takes 40 sec. to move same with scrolling....tried safe mode...still not working

Yippeee!!!!!!!!!!!! I solved the issue!!!! I didn't know what the hell Windows defender was. I have F-Secure antivirus that I pay for through my ISP because I like it and never realized that this Defender was running as well. I think the problem was due to two antivirus programs running at the same time because when I disabled the Defender I haven't had the problem since. I hope this works for you guys....totaljustice out!!

New Contributor

Re: keep getting Mozilla Firefox (not responding) arrow takes 40 sec. to move same with scrolling....tried safe mode...still not working

Hi Running windows 7 32bit, physical memory used 39% of 2GB. (Netbook) Running intel Atom. Firefox takes around 2minutes to start first time. Disabled all addins and restarted the machine. Firefox takes around 2 minutes to start. Often end up hitting the start multiple times believing it not to have started. Ok so I open IE and it opens in under 30seconds with all Addons enabled.

Firefox issue on this PC has been like this now for around 2 months. Will be moving away from firefox unless this is fixed much prefer Firefox over IE. I have read many many readers are having a startup problem with firefox.

Also recently the scroll down and across hang with a "Waiting" Circle before they react. It cannot be the loading of the page because I experience the same problem if I zoom in on a all ready loaded page and try to scroll.

New Contributor

Re: keep getting Mozilla Firefox (not responding) arrow takes 40 sec. to move same with scrolling....tried safe mode...still not working

Core2 Duo running WinXP Pro 32bit, 3 gigs mem, 28% used, over 200 gb HD space available. Firefox began to get slower and slower to load about 6 months ago - now it sometimes takes over a minute! I've tried disabling various other programs, including Defender - no help. Safe mode equally slow. I will NOT disable my Security Suite or firewall (Trend Micro)!

Occasional lockups after it does load - videos seem to "lose frames" sometimes (I have a fast cable connection - over 250 mb/sec download) and "N" wifi home network). IE doesn't act like this - it's fast to start and never hangs. Videos are clear and clean - none of the problems I have with Firefox.

Come on, Mozilla guys! You're losing your edge...

New Contributor

Re: keep getting Mozilla Firefox (not responding) arrow takes 40 sec. to move same with scrolling....tried safe mode...still not working

Iam having te same problem, B....y slow to start up frustrating have tried everything . is there any one out ther that can offer any sugestions