cancel
Showing results for 
Search instead for 
Did you mean: 

icon missing in address bar & tab & some bookmarks

Highlighted
New User

icon missing in address bar & tab & some bookmarks

After updating to ver 10.0.2 icon's are missing in address bar & tab & some bookmarks.

12 REPLIES
Senior User

Re: icon missing in address bar & tab & some bookmarks

Could you provide a screenshot to illustrate what you mean? Also, the latest version of Firefox is 11, so you could also try to upgrade do that first.

New User

Re: icon missing in address bar & tab & some bookmarks

Thursday, March 08, 2012 HI djst Updated to 11 this morning no change. Thanks for getting back to me this is a little screwy. I’ve attached 3 screen shots. #1-No icon shows up in the address or tab even though it shows on the favorite bar.#2&3 same thing except it shows in bookmarks & again not in the address or tab. This all started when I upgraded to 10, everything was fine in 7. What’s really strange is it screwed up IE8 also. Think I just messed this up you may get this reply twice.

2012-03-15-12-42-12-b64afe.png 2012-03-15-12-39-33-007204.png 2012-03-15-12-39-17-007204.png 2012-03-15-12-45-17-b64afe.png 2012-03-15-12-41-45-3b5981.png 2012-03-15-12-44-53-3b5981.png
Site Moderator

Re: icon missing in address bar & tab & some bookmarks

Did you try to restore the missing favicons with the CheckPlaces extension?

Try some maintenance on the places.sqlite database file:

If you can't restore the favicons then reset (delete) the places.sqlite database file.

New User

Re: icon missing in address bar & tab & some bookmarks

Saturday, March 17, 2012

Hi cor-el

In response to your last email .

cor-el wrote: "Did you try to restore the missing favicons with the CheckPlaces extension?

Yes- it restored about 90% of the bookmark favicons but did nothing for the address bar or tab. Some of the blank bookmarks are still good links but no icon & some are dead. There are over 1100.

Try some maintenance on the places.sqlite database file:

  • Places Maintenance

Yes-Installed it and ran it – no change

If you can't restore the favicons then reset (delete) the places.sqlite database file.

I have 9 partitions on a 1t HD. The “C” is dedicated to the OS only & in this case it’s XP w/sp3 & software that is used for or by the OS. It’s relatively small, 15gb, & is backed up weekly (only 8 min). All data usually on the “C” has been moved to the “I”(office) drive this includes, my docs,email, ie8 favorites, etc. I went back to Jan & copied over places.sqlite . All bookmarks were blank again !!

I updated to Firefox 11 & no change. I installed Google “CHROME” & imported bookmarks. All blank, no change . Don’t like chrome !

When this first started I reinstalled a “C” bu made in Jan. This had Firefox ver. 7 or 8 & I wound up with the same problem in both IE8 & Firefox. This is what’s so strange about this problem. When something like this comes up usually going back to a earlier version solves the problem but not this time. Another weird one is that some web pages will show a icon in the address bar but when you bookmark it there’s no icon ?!?!?!. SEE PICS.

Thank you for your help VEED68

2012-03-17-07-01-19-d0ce5a.png 2012-03-17-07-01-06-61f324.png
Site Moderator

Re: icon missing in address bar & tab & some bookmarks

Be aware that not all website have a favicon, so if you do not see one on the location bar and also no favicon on the Tools > Page Info > Media tab, then you have to assign a favicon yourself.

Build-in pages like the about:addons and the about:config page do not have a favicon and thus show the default empty square favicon instead.

  • chrome://mozapps/skin/places/defaultFavicon.png
New User

Re: icon missing in address bar & tab & some bookmarks

Sunday, March 18, 2012 Hi cor-el Their back!!! Well at least most of them. I’ve been working with pc’s a long time, since the late 60’s, & I must say this has been a real challenge which I still don’t fully understand. As I was trouble shooting this icon problem I recovered “places.sqlite” from a earlier bu, FEB 2012, but it made no change. I then realized that this file may been the updated V10 file so I went back to JAN. 2012 & put the whole folder zvjh4wt1.default in. Same problem only now all the bookmarks were blank. Now for the really bizarre part. !!!!!!!! I removed the JAN folder & put the original V11 back & they are. Icons now appear in the address bar & tab. I still have about 10% of the bookmarks blank, some are good links others are dead but the good ones still won’t show a icon anywhere. There is something corrupt in this program & there since is no way to separate the data from the program file I think I’m going to uninstall it, clean out the reg. & reinstall on the “I” drive so that a “C” reload can’t overwrite the data. Just read your reply. Every icon/ favicons in V7 (8?) was working in the bookmark, address bar & tab in both IE8 & Firefox. This all started when I updated to 10. What I don’t understand is why IE & CHROME (I imported from both) were affected since their data is in a different folder ??? see pics THANKS VEED68

2012-03-18-07-59-12-425c1a.png 2012-03-18-07-59-26-0fd9db.png 2012-03-18-07-58-58-2b1af6.png 2012-03-18-08-04-28-5a7287.png
New User

Re: icon missing in address bar & tab & some bookmarks

Well, thats just too deep for me to do. However, I did end up just opening every bookmark I had saved, and closing them. For some reason, it reset MOST of the favicons. However, there are still about 25% of them that never came back. Not even sure where they went or how they left to begin with. Thats the easiest way to fix it. I think Smiley Wink

New User

Re: icon missing in address bar & tab & some bookmarks

Sunday, April 15, 2012 HI Halofromsue Just a little history. Was doing a search about 2wks ago (good search - a charity search eng.) & clicked on a side link & it completely wiped out my computer. Came up as multiple system disk write errors & then came up with everything failing ,ram,hd,virises etc. & told me my key was expired ???? At that point I pulled the internet plug (USB) & shut down everything. Upon reboot I got the same thing & it would not boot to XP. I do weekly back ups so I attempted to reload to a older back & ran it a strange problem because none of my back ups were showing in the recovery tree. At this point your running off of a recovery cd &I was able to find them & reloaded the “C” partition & got everything up & running in a short time, but these SOB were really nasty. When I went to look at my other data,9 partitions, were blank !! They went & changed the attribute’s for every file to “HIDDEN”. They could just as easily wiped out everything !! I’m telling about this because after this happened I uninstalled Firefox & installed Chrome which is a “Sandbox” browser that runs scripts inside a “virtual” environment. Chrome gave the same trouble with the favicons & I’ve tried several addon’s & utilitys but none of them worked. Opening every link,there are over 1000, is time consuming but I’ve managed to get about 75% of them to show. Before upgradeing to 10 all favicons were showing in all browsers !!!! Something was change in the OS when Firefox 10 was installed since 3 browsers now have the same problem, IE8, Firefox, & now Chrome & all three keep their data in different places. Thank’s Veed

New User

Re: icon missing in address bar & tab & some bookmarks

I have updated to 14.0.1 and still do not have icons on address bar. Most of my bookmarks have lost their icons also.

2012-08-05-11-33-47-f562bb.png