cancel
Showing results for 
Search instead for 
Did you mean: 

firefox 5 for mac ppc tiger 10.4.11

Highlighted
New Contributor

firefox 5 for mac ppc tiger 10.4.11

firefox 5 for mac ppc tiger 10.4.11

1 REPLY
Support Forum Moderator

Re: firefox 5 for mac ppc tiger 10.4.11

For older Macs that aren't supported in Firefox 4.0 & 5.0, try TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8 .
http://www.floodgap.com/software/tenfourfox/