cancel
Showing results for 
Search instead for 
Did you mean: 

could not find mozilla runtime. firefox 5.0.1. I searched the build and there is no file called firefox-bin

Highlighted
New Contributor

could not find mozilla runtime. firefox 5.0.1. I searched the build and there is no file called firefox-bin

linux 2.6.39, GCC 4.6.0

Compiled and installed XULRunner 5.0.1. I don't know how to test it, so I assume it's ok.

Compiled firefox 5.0.1 with use_LIBXUL_DIST.patch and the correct configure switches --with-system-xul --with-xul-sdk=.... or somesuch.

Running firefox ALWAYS gives this response: Could not find mozilla runtime.

I tried replacing /usr/bin/firefox with a symlink to /usr/lib64/firefox-5.0.1/firefox.

I tried renaming it firefox-bin.

I tried editing run-mozilla.sh to call 'firefox' instead of 'mozilla-bin'.

I tried export PATH=$PATH:/usr/lib64/xulrunner-5.0.1:/usr/lib64/xulrunner-devel-5.0.1/bin:/usr/lib64/firefox-5.0.1 export LD_LIBRARY_PATH=/usr/xulrunner-devel-5.0.1/lib:/usr/lib64/firefox-5.0.1

I tried recompiling. I searched the source tree and the build tree for 'firefox-bin' and 'mozilla-bin'. Not found.

I tried compiling firefox 3.xxxx, but it will not compile with GCC 4.6.0. It wants -fpermissive, but adding that to the mozconfig file made no difference. Trying 'alias c++="c++ -fpermissive"' made no difference. Trying CXX="c++ -fpermissive" made no difference.

1 REPLY
Site Moderator

Re: could not find mozilla runtime. firefox 5.0.1. I searched the build and there is no file called firefox-bin

Try this mozillaZine forum: