cancel
Showing results for 
Search instead for 
Did you mean: 

adobe reader xi cannot be 'enabled' once it is installed. FF told me to get the latest version as old version was unsafe.what do i do?

Highlighted
New Contributor

adobe reader xi cannot be 'enabled' once it is installed. FF told me to get the latest version as old version was unsafe.what do i do?

adobe reader xi cannot be 'enabled' in FF once it is installed. FF told me to get the latest version as old version was unsafe. what do i do?

(win7) (FF18.01).
5 REPLIES
Legendary Contributor

Re: adobe reader xi cannot be 'enabled' once it is installed. FF told me to get the latest version as old version was unsafe.what do i do?

Disable the Adobe plugin and use the Firefox default PDF viewer

New Contributor

Re: adobe reader xi cannot be 'enabled' once it is installed. FF told me to get the latest version as old version was unsafe.what do i do?

i'm not computer saavy. mozilla disabled my old version of adobe reader. how can i download the latest version?

Site Moderator

Re: adobe reader xi cannot be 'enabled' once it is installed. FF told me to get the latest version as old version was unsafe.what do i do?

There are other things that need your attention.

Please Update to the latest Firefox 20.0.x version.

  • Help > About Firefox

The Firefox Firefox/18.0 version that you currently run is no longer supported with security updates


New Contributor

Re: adobe reader xi cannot be 'enabled' once it is installed. FF told me to get the latest version as old version was unsafe.what do i do?

i think i downloaded mozilla 20 but not sure.

New Contributor

Re: adobe reader xi cannot be 'enabled' once it is installed. FF told me to get the latest version as old version was unsafe.what do i do?

i think i downloaded mozilla 20 but not sure.