cancel
Showing results for 
Search instead for 
Did you mean: 

You have conficting info about the new Firefox; the info and system requirements are for version 3.5.19 but the download is for 4.01. Will version 4.01 work on a mac PPC running OSX 4.11?

Highlighted
New Contributor

You have conficting info about the new Firefox; the info and system requirements are for version 3.5.19 but the download is for 4.01. Will version 4.01 work on a mac PPC running OSX 4.11?

Question You have conficting info about the new Firefox; the info and system requirements are for version 3.5.19 but the download is for 4.01. Will version 4.01 work on a mac PPC running OSX 4.11?

1 REPLY
Legendary Contributor

Re: You have conficting info about the new Firefox; the info and system requirements are for version 3.5.19 but the download is for 4.01. Will version 4.01 work on a mac PPC running OSX 4.11?

Sorry, that is confusing. Firefox 4 is for Intel-based Macs only.

You should be able to run 3.6.17 on a PPC Mac.

Info: http://www.mozilla.com/en-US/firefox/3.6.13/system-requirements/

Download: http://www.mozilla.com/firefox/all-older