cancel
Showing results for 
Search instead for 
Did you mean: 

Yahoo! recommending Firefox 16 for Windows 2000 users

Highlighted
New User

Yahoo! recommending Firefox 16 for Windows 2000 users

http://downloads.yahoo.com/firefox/sysreq states

Mozilla Firefox Optimized for Yahoo! System Requirements Windows Operating Systems

Windows 2000, XP, Server 2003, Vista or 7

Dear Yahoo! do NOT rub salt in my wound.

5 REPLIES
Regular User

Re: Yahoo! recommending Firefox 16 for Windows 2000 users

Hi there,

Looks like Yahoo! haven't updated the System Requirements on their site for a while.

Have you contacted them to notify them of their error?

Thanks

Site Moderator

Re: Yahoo! recommending Firefox 16 for Windows 2000 users

Note that for now you can still use the Firefox 10 ESR version on Windows 2000 until they switch to Firefox 18.
That version still gets security updates.

New User

Re: Yahoo! recommending Firefox 16 for Windows 2000 users

I tweeted Yahoo and they said they would look into it.

I've looked into Firefox 10 ESR and I think I'll stick with Firefox 12.

2012-10-28-12-31-39-341500.png
Site Moderator

Re: Yahoo! recommending Firefox 16 for Windows 2000 users

Firefox 10.0.* is more up to date security wise compared to the old Firefox 12.0 as it does not have the security patches that the newer versions have.

Also you may be able to get Firefox 13.0 and newer to work on Win2000 as per http://forums.mozillazine.org/viewtopic.php?f=23&t=2482475

New User

Re: Yahoo! recommending Firefox 16 for Windows 2000 users

here is how i installed firefox 16 on windows 2000

http://www.youtube.com/watch?v=1j7QZYOJUNw

if this is confusing just reply for help

good luck!