cancel
Showing results for 
Search instead for 
Did you mean: 

Windows xp old desktop, downloaded firefox, able to search web with google in top righthand corner, but can't search using the firefox search box, why not?

Highlighted
New Contributor

Windows xp old desktop, downloaded firefox, able to search web with google in top righthand corner, but can't search using the firefox search box, why not?

Computer novice, with old windows xp desktop, changed to firefox, have firefox as homepage, but can't use the central firefox search box, I type a word, click on search .......and....wait.......nothing happens. Have been able to use the top right hand corner search box (set on google). Not great with computers, so feel like I'm really missing something basic! Help! Thanks!

3 REPLIES
Site Moderator

Re: Windows xp old desktop, downloaded firefox, able to search web with google in top righthand corner, but can't search using the firefox search box, why not?

hello, please see if installing the search reset addon can resolve the issue: https://addons.mozilla.org/firefox/addon/searchreset/ (a restart of the browser is necessary afterwards).

Site Moderator

Re: Windows xp old desktop, downloaded firefox, able to search web with google in top righthand corner, but can't search using the firefox search box, why not?

You can check if you still have the XML files of the default search engines in the searchplugins folder in the Firefox program folder.

  • (32 bit Windows) C:\Program Files\Mozilla Firefox\
  • (64 bit Windows) C:\Program Files (x86)\Mozilla Firefox\

If not then you need to reinstall Firefox.


You can delete the search.json file and a possible search.sqlite file in the Firefox Profile Folder.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder
New Contributor

Re: Windows xp old desktop, downloaded firefox, able to search web with google in top righthand corner, but can't search using the firefox search box, why not?

Big thanks to both of you, somehow ended up trying both methods, then when I started computer all is working as it should be, thanks again for helping a novice like me, it's good to know friendly advice can be found!