cancel
Showing results for 
Search instead for 
Did you mean: 

Why does Firefox 21.0 display "TypeError: this.handleDownloadEvent is not a function" when I use S3 Fox Organizer 0.7 to download a file from Amazon S3?

SOLVED
Highlighted
New Contributor

Why does Firefox 21.0 display "TypeError: this.handleDownloadEvent is not a function" when I use S3 Fox Organizer 0.7 to download a file from Amazon S3?

I'm still able to download files from S3, but I have to click the OK button on this annoying alert for each file downloaded. I imagine you must have (once again) changed something about your APIs. The last time you did so, it completely broke S3Fox, but I was able to provide the developer with the API details necessary to update his tool (to version 0.7).

If you provide the technical details for this problem as well, I'd be happy to forward them to the developer.

1 ACCEPTED SOLUTION

Accepted Solutions
Site Moderator

Re: Why does Firefox 21.0 display "TypeError: this.handleDownloadEvent is not a function" when I use S3 Fox Organizer 0.7 to download a file from Amazon S3?

there's a version 0.8 of this extension available - can you check if you get the same error with that one?

2 REPLIES
Site Moderator

Re: Why does Firefox 21.0 display "TypeError: this.handleDownloadEvent is not a function" when I use S3 Fox Organizer 0.7 to download a file from Amazon S3?

there's a version 0.8 of this extension available - can you check if you get the same error with that one?

New Contributor

Re: Why does Firefox 21.0 display "TypeError: this.handleDownloadEvent is not a function" when I use S3 Fox Organizer 0.7 to download a file from Amazon S3?

Hi phillipp,

That did indeed fix the problem. I had to look around a bit to find S3Fox 0.8, however. The latest download from the developer's site is apparently still 0.7. However, I was able to download 0.8 from a page on the Mozilla site that seemed to suggest that this was a Thunderbird(?) add-on:

https://addons.mozilla.org/en-US/thunderbird/addon/amazon-s3-organizers3fox/eula/190250?src=version-...

It's difficult for me to imagine how useful this tool would be in that context, but I was able to install the amazon_s3_organizers3fox-0.8-fx.xpi file I downloaded into Firefox using its Add-ons Manager, and that removed the problem.

THANKS!

- Chris