cancel
Showing results for 
Search instead for 
Did you mean: 

Why do you keep asking me to load the newest version? I have done this five times with no results...I loved my old firefox!!!

Highlighted
New Contributor

Why do you keep asking me to load the newest version? I have done this five times with no results...I loved my old firefox!!!

I cant seem to upgrade and its screwing up all my other applications...

2 REPLIES
Expert Contributor

Re: Why do you keep asking me to load the newest version? I have done this five times with no results...I loved my old firefox!!!

Hi,

You can try to manually download the latest and upgrade: https://www.mozilla.org/en-US/firefox/new/

You may also want to backup your current Firefox profile/settings/personal data before upgrading.

3.6 UI

Common questions

Add-ons

If problems persist you can Reset Firefox (a new feature) and start afresh.

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Site Moderator

Re: Why do you keep asking me to load the newest version? I have done this five times with no results...I loved my old firefox!!!

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.25) Gecko/20111212 Firefox/3.6.25 ( .NET CLR 3.5.30729) FBSMTWB

Your Firefox useragent is stuck at Firefox 3.6.25 due to Fast Browser Search having been installed when you had Firefox 3.6.25.

See https://support.mozilla.org/en-US/kb/websites-say-firefox-outdated-or-incompatible