cancel
Showing results for 
Search instead for 
Did you mean: 

Why do videos in Firefox play slow or out of sync from the audio ?

Highlighted
New Contributor

Why do videos in Firefox play slow or out of sync from the audio ?

Videos played either through Youtube or Vimeo play the audio mostly fine, but the video lags, stalls, freezes, sometimes catches up briefly, but generally out of sync. This happens whether in Flash or HTML5. I have also tried the latest Chrome, and it happens there too (although HTML5 stutters).

I have an XP Pro laptop. AMD 2600 Athlon 2GHz. Service Pack 2. Internet connection is 30Mb/s.

Flash 11 and Firefox 26 are completely up to date.

If I play video through Media Player Classic or VLC there is no lag problem.

I have tried over a week: resetting firefox, disabling add ons, cleaning registry, removing spyware, removing unused programs, viewing Youtube in HTML5, and editing registry according to various forums. None have worked.

This never used to be a problem, but got progressively worse with each FIrefox update. But remember, is also happens on Chrome (which I never use, but thought I would test).

Incidentally, while I was trying various things, I tried to update the driver for my display adapter. It could not install, so now there are no drivers.

Please help. I'm going crazy trying to solve this. And I am not a computer geek, so please write in plain English.

3 REPLIES
Legendary Contributor

Re: Why do videos in Firefox play slow or out of sync from the audio ?

I don't think its the players or the browsers. Its whoever created / posted the clip. I have found many clips that do not sync properly on many sites. But I mostly find properly sync clips on those same sites.

New Contributor

Re: Why do videos in Firefox play slow or out of sync from the audio ?

It's not "the" clip. It's every clip. But not if I download them, and reply through a media player program.

New Contributor

Re: Why do videos in Firefox play slow or out of sync from the audio ?

I got the same problem, runs fine in IE though. Chrome has the same problem. If i download a 1080p it runs 100% smooth, when i watch on vimeo, espacially full screen is shocks with + - 10 fps, and horizontal and vertical tearing.

my specs are : inter duo 6600 @ 2.4 Ghz, 4GB ram, windows 7, ATI X1900,

things i already did: disable all add-ons, reset firefox, downgrading firefox, upgrading firefox, updating windows, virus scanner, updating video driver, downgrading video driver, updating flash, downgrading flash,

i really appreciate help, the only think i could think of maybe its the video card is to old? but then it had to work with older version of firefox. like it did before.