cancel
Showing results for 
Search instead for 
Did you mean: 

Why aren't my add-ons enabling?

SOLVED
Highlighted
New Contributor

Why aren't my add-ons enabling?

I recently updated Firefox while my add-ons were disabled. Normally this would fall under the "Re-enable add-ons" thread you guys already have, but I'm not getting an error message about the add-ons. I just tried to re-enable them about five times (along with a couple days ago), and while I can get it to say "these will be enabled when you restart Firefox", restarting it doesn't enable them. They just go back to being disabled. The ones I want to enable are NoScript and DownloadHelper.

1 ACCEPTED SOLUTION

Accepted Solutions
Site Moderator

Re: Why aren't my add-ons enabling?

hello, this sounds like the files in your profile folder that store the information about your extensions might have become corrupted. please go to firefox > help > troubleshooting information > profile - show folder... then windows explorer should open up your profile folder. in there look for the files named extensions.ini, extensions.sqlite, extensions.sqlite-journal (and in some cases also extensions.txt, extensions.rdf). delete or rename those files and quit firefox, they will be regenerated the next time you launch firefox.

also see Corrupt extension files

3 REPLIES
Site Moderator

Re: Why aren't my add-ons enabling?

hello, this sounds like the files in your profile folder that store the information about your extensions might have become corrupted. please go to firefox > help > troubleshooting information > profile - show folder... then windows explorer should open up your profile folder. in there look for the files named extensions.ini, extensions.sqlite, extensions.sqlite-journal (and in some cases also extensions.txt, extensions.rdf). delete or rename those files and quit firefox, they will be regenerated the next time you launch firefox.

also see Corrupt extension files

New Contributor

Re: Why aren't my add-ons enabling?

Thanks so much! Have a fun rest of your day!

New Contributor

Re: Why aren't my add-ons enabling?

I encountered a similar problem, and tried the solution suggested here. It did not work, and I was hassled with a lengthy series of tabs asking me to verify each add-on installation individually. (It even implied, incorrectly, that I needed to restart after each such approval.) Afterwards, my add-ons all still showed as being disabled in the sidebar, even though they were, in fact, working. Furthermore, the Enable and Disable buttons were not doing anything.

I decided the culprit might be All-in-One Sidebar. I installed the latest version, and the problem disappeared. In retrospect, I suspect that about:addons would have worked. It was just the sidebar access to add-ons that was fouled up.