cancel
Showing results for 
Search instead for 
Did you mean: 

When using the Kunena forum at the Lwks.com site, it is not possible to add images to a post with FF18.0

SOLVED
Highlighted
New User

When using the Kunena forum at the Lwks.com site, it is not possible to add images to a post with FF18.0

I am a regular user of the Kunena-based forum at lwks.com. Kunena is a Joomla extension. I have been using this forum using Firefox for the past two years without problem. After updating to FF18.0 yesterday, I now find that I cannot insert images or other files into forum posts. When I click on the Add File button and select a file (e.g. jpg) the path to the file on my desktop no longer appears in the Add file box and the Insert button is missing so I am unable to insert the file as an attachment to the forum post.

1 ACCEPTED SOLUTION

Accepted Solutions
New User

Re: When using the Kunena forum at the Lwks.com site, it is not possible to add images to a post with FF18.0

Try changing the following 2 files:

in /components/com_kunena/template/default/js/editor.js

var input = __file.getElement('input.kfile-input')

to

var input = __file.getElement('input.kfile-input.hidden')


in /components/com_kunena/template/default/js/editor-min.js

var a=c.getElement("input.kfile-input").set

to

var a=c.getElement("input.kfile-input.hidden").set

25 REPLIES
New User

Re: When using the Kunena forum at the Lwks.com site, it is not possible to add images to a post with FF18.0

It was an issue with Mootools library not FF18

Mootools function getElement( "input.kfile-input" ) was finding

<input class="kfile-input-textbox"> instead of <input class="kfile-input hidden">

fixed by using getElement( "input.kfile-input.hidden " ) instead

Thanks for reporting.

New User

Re: When using the Kunena forum at the Lwks.com site, it is not possible to add images to a post with FF18.0

Many thanks for your reply.

New User

Re: When using the Kunena forum at the Lwks.com site, it is not possible to add images to a post with FF18.0

having the same problem using joomla 1.5 with kunena however we have a test site using joomla 2.5 and that works ok. Still have this issue

New User

Re: When using the Kunena forum at the Lwks.com site, it is not possible to add images to a post with FF18.0

Try changing the following 2 files:

in /components/com_kunena/template/default/js/editor.js

var input = __file.getElement('input.kfile-input')

to

var input = __file.getElement('input.kfile-input.hidden')


in /components/com_kunena/template/default/js/editor-min.js

var a=c.getElement("input.kfile-input").set

to

var a=c.getElement("input.kfile-input.hidden").set

New User

Re: When using the Kunena forum at the Lwks.com site, it is not possible to add images to a post with FF18.0

Many thanks fro the response.

SOLVED

New User

Re: When using the Kunena forum at the Lwks.com site, it is not possible to add images to a post with FF18.0

Thanks WooDzu alas it did not work on our site.

New User

Re: When using the Kunena forum at the Lwks.com site, it is not possible to add images to a post with FF18.0

What version is your site running?

Our is MooTools 1.2.5 (from MooTools Upgrade plugin), a minified and compressed version.

New User

Re: When using the Kunena forum at the Lwks.com site, it is not possible to add images to a post with FF18.0

Same version

New User

Re: When using the Kunena forum at the Lwks.com site, it is not possible to add images to a post with FF18.0

I could take a quick look if you share your site's URL