cancel
Showing results for 
Search instead for 
Did you mean: 

When I try to go to washpost.com (my homepage), I am redirected to m.washpost.com (mobile site) - site begins to load, then redirects over and over again.

Highlighted
New User

When I try to go to washpost.com (my homepage), I am redirected to m.washpost.com (mobile site) - site begins to load, then redirects over and over again.

This is new issue as this morning t was running fine then I refreshed home page and browser got into a loop of attempts to keep loading (desktop version of page) and then redirecting back to mobile version. Over and over. I clear cache and cookies and the Loop stops (temporarily) but the redirects to the mobile page seems to now be the default response to the www.washingtonpost.com site for this browser. Works fine in safari and chrome. So...i upgraded to ff14 (whihc I had been waitng on and same deal thing still occurs.

9 REPLIES
Regular User

Re: When I try to go to washpost.com (my homepage), I am redirected to m.washpost.com (mobile site) - site begins to load, then redirects over and over again.

Your user agent may have changed.

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Mozilla Support Contributor

Re: When I try to go to washpost.com (my homepage), I am redirected to m.washpost.com (mobile site) - site begins to load, then redirects over and over again.

If you don't mind digging under the covers, you could try changing your useragent directly. See Websites say that Firefox is outdated or incompatible even though it's the latest version.

Mozilla Support Contributor

Re: When I try to go to washpost.com (my homepage), I am redirected to m.washpost.com (mobile site) - site begins to load, then redirects over and over again.

Do you have your cookie management set to "ask me every time"? A new cookie-related issue has emerged for some websites that causes inexplicable behavior. Please see these threads for examples and a workaround:

New User

Re: When I try to go to washpost.com (my homepage), I am redirected to m.washpost.com (mobile site) - site begins to load, then redirects over and over again.

I tried changing user agent directly but no solution there. Moving on the default procedure but not excited about reinstalling extension and addons. oh well.

Regular User

Re: When I try to go to washpost.com (my homepage), I am redirected to m.washpost.com (mobile site) - site begins to load, then redirects over and over again.

Does it work on IETab?

New User

Re: When I try to go to washpost.com (my homepage), I am redirected to m.washpost.com (mobile site) - site begins to load, then redirects over and over again.

I assume you meant IE user agent. Tried it but still no go.

Regular User

Re: When I try to go to washpost.com (my homepage), I am redirected to m.washpost.com (mobile site) - site begins to load, then redirects over and over again.

Site Moderator

Re: When I try to go to washpost.com (my homepage), I am redirected to m.washpost.com (mobile site) - site begins to load, then redirects over and over again.

marcsances, please check on which platform the OP is before doing suggestions about using IE. On a Mac that doesn't apply and thus isn't possible.

See also:

Regular User

Re: When I try to go to washpost.com (my homepage), I am redirected to m.washpost.com (mobile site) - site begins to load, then redirects over and over again.

Ok, ok, don't get angry, please... Maybe the source of the problem is not the user agent, maybe just it detects he/she has Mac OS and thinks he/she has an iOS device. Just tell us: how do you perform redirect to mobile version? Do you detect user agent, or you use another method?