cancel
Showing results for 
Search instead for 
Did you mean: 

Video controls do not show

Highlighted
New User

Video controls do not show

Whenever i play a video, whether quicktime or html5, there are no video controls (play, pause etc). On trailers.apple.com, I can get the video controls to show up if click inspect element but then there's no video. I have tried reinstalling firefox, vlc, quicktime, flash, with no success. I'm using Winx64 fully patched.

23 REPLIES
Site Administrator

Re: Video controls do not show

Hi aplhaace,

Thank you for contacting support, I understand that there are no video controls whenever a video is played in the Firefox Browser. We are happy to help.

It looks like the plug ins used for video are disabled in the Plug in menu, based on the troubleshooting information. Please enable them and please post back.

We look forward to hearing from you.

guigs

Site Administrator

Re: Video controls do not show

Another thing we can try is launching the browser in safe mode. Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

New User

Re: Video controls do not show

Hi,

I have made sure that my plugins are enabled (specifically quicktime and shockwave flash) and there are still no controls.

I also tried safe mode and again, no video controls. What's next?

Site Moderator

Re: Video controls do not show

So, no controls here either when you hover the video?

Do you see a "Show Controls" or "Hide Controls" in the right-click context menu

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
New User

Re: Video controls do not show

Hi,

So http://www.mozilla.org/en-US/firefox/video/ has the controls.

Any trailer on trailers.apple.com does not have the controls. For instance, http://trailers.apple.com/trailers/wb/islandoflemursmadagascar/#videos-large

has no video controls. However if I right click and inspect element, then the video controls appear there (but there is no video).

Site Administrator

Re: Video controls do not show

One or the other work, weird

Long shot would there be any firewalls or anti-virus software that is running while the trailer is watched? Ref:[[ http://kb.mozillazine.org/Resetting_preferences#Software_that_changes_preference_settings]]

Another thing to check is to open up the Web Console while you watch the movie in developer tools and see if there are any errors for objects loading on the page. If there is an error message, that might hint to what is blocking it.

Site Moderator

Re: Video controls do not show

Do you see the full video as the controls may be hidden in case the player window is not high enough to include the area with the controls?

New User

Re: Video controls do not show

Hi,

I disabled all firewalls and antivirus -- still the same thing. I don't think my firewalls/etc are causing the issue as the controls appear just fine under chrome.

I also think this get's to cor-el's issue-- since the controls appear just fine under chrome, I don't think the window being not high enough is the issue. Here is the output from the web console:

[12:39:50.705] GET http://trailers.apple.com/trailers/wb/thehobbitthedesolationofsmaug/includes/large.html [HTTP/1.1 200 OK 35ms] [12:39:51.476] GET http://trailers.apple.com/trailers/wb/thehobbitthedesolationofsmaug/includes/sneakpeek/large.html [HTTP/1.1 200 OK 34ms] [12:39:52.200] GET http://trailers.apple.com/trailers/wb/thehobbitthedesolationofsmaug/includes/settings/thehobbit2-sne... [HTTP/1.1 304 Not Modified 36ms] [12:39:52.201] GET http://trailers.apple.com/trailers/global/v3.1/includes/ac_media_languages/en-US.json [HTTP/1.1 304 Not Modified 36ms] [12:39:52.160] Error in parsing value for 'margin-right'. Declaration dropped. @ http://trailers.apple.com/trailers/wb/thehobbitthedesolationofsmaug/#videos-large [12:39:52.160] Error in parsing value for 'margin-left'. Declaration dropped. @ http://trailers.apple.com/trailers/wb/thehobbitthedesolationofsmaug/#videos-large [12:39:52.162] Error in parsing value for 'width'. Declaration dropped. @ http://trailers.apple.com/trailers/wb/thehobbitthedesolationofsmaug/#videos-large

Site Administrator

Re: Video controls do not show

So I got those errors and Mutation Api errors and those are usually inside of an extension. However I investigated the css file for the apple video controls and one of the css margin-left attributes has a "_" in front of it. Definitely might need to contact the developer of that css file.

I reloaded the page and tried to capture it again and I had to click on the video controls and hover over them to get the errors again.

These errors are CSS styling errors. Please try safe mode one more time after clearing the cache. Last idea is to create a new profile.

Reference for the errors of api I got that might not be the issue [http://stackoverflow.com/questions/19.../how-do-i-use-mutationobserver-instead-of-mutation-events]