cancel
Showing results for 
Search instead for 
Did you mean: 

Tried to install Firefox 14.0.1. Won't install, says I need XP, but I have XP.

SOLVED
Highlighted
New User

Tried to install Firefox 14.0.1. Won't install, says I need XP, but I have XP.

Downloaded Firefox 14.0.1. Would not install. Got message: "This version of Firefox requires Microsoft Windows XP SP2 or newer."

I have dial-up and it took an hour to load, now it won't install. Very frustrating, particularly as I have Windows XP. Why won't it load?

Thank you.

1 ACCEPTED SOLUTION

Accepted Solutions
Site Moderator

Re: Tried to install Firefox 14.0.1. Won't install, says I need XP, but I have XP.

So that explains it. Windows XP SP1 is no longer supported.

You will have to update to SP2 or SP3 to keep continuing using Firefox.

9 REPLIES
Site Moderator

Re: Tried to install Firefox 14.0.1. Won't install, says I need XP, but I have XP.

Make sure that you do not run Firefox in compatibility mode.

You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab.

Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

New User

Re: Tried to install Firefox 14.0.1. Won't install, says I need XP, but I have XP.

I checked and there is nothing selected in the compatibility tab.

Site Moderator

Re: Tried to install Firefox 14.0.1. Won't install, says I need XP, but I have XP.

Which service pack do you have installed?

  • Control Panel > System
New User

Re: Tried to install Firefox 14.0.1. Won't install, says I need XP, but I have XP.

Service pack 1.

Site Moderator

Re: Tried to install Firefox 14.0.1. Won't install, says I need XP, but I have XP.

So that explains it. Windows XP SP1 is no longer supported.

You will have to update to SP2 or SP3 to keep continuing using Firefox.

New User

Re: Tried to install Firefox 14.0.1. Won't install, says I need XP, but I have XP.

Okay. Thank you.

Site Moderator

Re: Tried to install Firefox 14.0.1. Won't install, says I need XP, but I have XP.

You're welcome

New User

Re: Tried to install Firefox 14.0.1. Won't install, says I need XP, but I have XP.

Untrue. I have not updated to SP2 or 3. I have updated Firefox to Ver 6, which works fine. The correct statement is that you will not have the current level of security in FF or Win (and perhaps there are features that don't work properly but I've yet to encounter them).

Support Forum Moderator

Re: Tried to install Firefox 14.0.1. Won't install, says I need XP, but I have XP.

billyrave,

You are talking about Firefox 6.0 working with WinXP SP1, but the original poster in this thread was talking about Firefox 14.0.1.