cancel
Showing results for 
Search instead for 
Did you mean: 

Trend Micro Toolbar not working in Firefox 19 -- is there a fix?!

Highlighted
New User

Trend Micro Toolbar not working in Firefox 19 -- is there a fix?!

I just migrated my whole household from IE to FIrefox 19. All's working well, except for the Trend Micro toolbar. Now this toolbar includes three add-ons from Trend which together work brilliantly on IE. But, not on Firefox.

The toolbar is supposed to block dangerous sites, and scan and rate links before you click on them (for example, it scans ever google search result), and then gives you a visual to tell you if it's safe or not. It highlights links green that are safe, and hovering brings up a tooltip with details.

 It doesn't work in Firefox. Doesn't even show up.

It's Trend Micro Titanium Maximum Security 2013, and Firefox 19. I heard there was a fix for Firefox version 17, but couldn't find anything for the current version.

Is there any way to make it work? It's quite important to help my family members and I choose what new, unfamiliar sites are safe and which we should avoid. It's to the point that I've advised my less-computer-literate family members to use IE if the lack of link rating makes them uncomfortable. We did get Adblock though. First thing I did. Smiley Happy

4 REPLIES
SUMO Contributor

Re: Trend Micro Toolbar not working in Firefox 19 -- is there a fix?!

The latest I found was the hotfix for Firefox 17: Page rating do not work after upgrading to Mozilla Firefox version 17. However, when I installed it on Titanium Maximum Security 2012 (I haven't updated to 2013 yet), restarted Firefox, enabled the extensions, and restarted again, it worked! I only tested the Google results so far.

2013-03-18-22-14-22-336454.png 2013-03-18-22-21-48-9161d0.png
SUMO Contributor

Re: Trend Micro Toolbar not working in Firefox 19 -- is there a fix?!

Hmmm, the missing screen shot:

2013-03-18-22-22-55-9161d0.png
New User

Re: Trend Micro Toolbar not working in Firefox 19 -- is there a fix?!

well, I finally got the TM Toolbar ratings working on Firefox (now version 20) with Trend Titanium 2013. I reinstalled the hotfix which I had previously installed for Firefox17 from this location- http://esupport.trendmicro.com/solution/en-us/1095837.aspx

Perhaps that page could be updated to indicate the hotfix works for Firefox 19 and 20 also????? Thank you jscher for the lead.

Site Moderator

Re: Trend Micro Toolbar not working in Firefox 19 -- is there a fix?!

To jscher2000:

My experience is that it can take a few minutes to make an attached image appear if you edit a reply and add additional images, so you need to be patient (may be worth to report this on the contributors forum or file a bug to disable/invalidate the cache in this case).