cancel
Showing results for 
Search instead for 
Did you mean: 

Streaming video lags while Audio continues normally when switching tabs

Highlighted
New Contributor

Streaming video lags while Audio continues normally when switching tabs

It only happens if I go from a streaming video tab to another tab or browser screen/software etc. anything that switches the main view of my screen from the video and back will cause this problem.

it will play fine at first, but once I look at facebook or bring up itunes etc, and switch back (usually doesnt occur right away, but once the video is a minute or two in it will 100%) the video will start to lag horribly and will never get back on track. the play buttons on youtube/netflix even stay as pause buttons even though I can click play and pause back and forth functionally, and the audio will never skip a beat, but the video will stop dead, lag a few frames and stop dead again and will never correct unless I refresh the page. I can't recreate this in chrome, I've cleared my history and caches, upped the storage size on the main cache and tried updating various things like flash and firefox (19.0) but nothing is solving it!

4 REPLIES
Site Moderator

Re: Streaming video lags while Audio continues normally when switching tabs

You can check for problems caused by recent Flash updates and try these:

  • disable hardware acceleration in the Flash plugin
  • disable protected mode in Flash 11.3 and later (?)
New Contributor

Re: Streaming video lags while Audio continues normally when switching tabs

I forgot to mention that I have a macbook pro 2010 model

New Contributor

Re: Streaming video lags while Audio continues normally when switching tabs

the above did not solve the issue. I don't want to have to switch to chrome so can anyone help me out?

New Contributor

Re: Streaming video lags while Audio continues normally when switching tabs

any help would be appreciated.. retested and it only happens when switching tabs/ firefox browser screens, not other applications, so its 100% firefox. can you please fix your bugs or atleast someone reply?