cancel
Showing results for 
Search instead for 
Did you mean: 

Site identity button not working on any site; only displays 'this website does not supply identity information' for everything

Highlighted
New User

Site identity button not working on any site; only displays 'this website does not supply identity information' for everything

I just upgraded to version 14.0.1 and the site identity button isn't working at all. It only displays the grey globe for every website, telling me (even for this website) 'this website does not supply identity information' -- and I know most of these websites are encrypted and legitimate. There is no Favicon, no nothing, and I'm not sure what's wrong. Help, please?

5 REPLIES
Site Moderator

Re: Site identity button not working on any site; only displays 'this website does not supply identity information' for everything

See Site Identity Button:


Are you using a custom theme that may not be compatible?

Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

New User

Re: Site identity button not working on any site; only displays 'this website does not supply identity information' for everything

Hmm, so I guess there's no favicons anymore? That's fine, I was worried there was something wrong in that regard. So the gray globe icon is just the standard now -- I should have probably looked harder for that information. But I'm not using any custom themes, so is "this website does not supply identity information" something that will come up with sites like Tumblr and Hotmail and so on? The padlock and green lock icon still appears, but now I'm just wondering about that message.

New User

Re: Site identity button not working on any site; only displays 'this website does not supply identity information' for everything

I just wish someone had the answer to "this website does not supply identity information". All I have seen so far is that I might need to go to https protocol. Well, if that is true, please say so. If it is true then "http" will be going away soon and everyone will have to pay the money for an SSL certificate. And, we will be no better off but we will be more poor!

This is dumb. So, what is the story? Do we really need to go "https" or can we provide the "identity information" in some fashion? What is the "identity information" is the basic question.

Site Moderator

Re: Site identity button not working on any site; only displays 'this website does not supply identity information' for everything

New User

Re: Site identity button not working on any site; only displays 'this website does not supply identity information' for everything

Since upgrading to FF14, when I try to sign in to eBay the secure site identity button appears briefly when the page is loading but then reverts to the gray globe with the message ""this website does not supply identity information". Amazon gives me a gray padlock, but not the normal secure site identity button. How can I be sure I'm not being redirected to a phishing site if this feature doesn't work?

PS - I couldn't sign in to this forum on FF either, it told me I had to enable cookies even though they were enabled for *mozilla.org. Had to post from IE!!

--Using Win XP Pro SP3, FF14.0.1. Default theme, add ons are BlockSite 0.7.1.1 (I don't recall adding this. Is it a replacement for ad block?), Quick Java 1.7.7, Status 4-Evar 2012... these last two need to be updated, will do that now.

Update 9/22/12 - Seems to be fixed in FF 15. Thanks!