cancel
Showing results for 
Search instead for 
Did you mean: 

Search Engine Favorite Icons Broke in Linux but Not Windows

Highlighted
New User

Search Engine Favorite Icons Broke in Linux but Not Windows

I usually use FEBE to make a back up of my firefox profile and I use it to restore it. In this case I forgot to do that before I did a clean install of Kubuntu 12.10 on my new SSD. So I just decided to copy over my profile folder(~/.mozilla/firefox/) from my old Kubuntu 12.10 back up. I used the firefox profile manager to select the copied over profile. Everything worked fine but the search engine icons were missing when I opened the menu. However, when I select a search engine, the icon shows up fine. Since I am doing a dual boot with Win 8, I did a FEBE back up and transported the profile back up to Win 8. In Win 8 the icons work as designed. When I open the search engine drop down menu, it all the icons show as they should. So I did a FEBE back up of the Win 8 profile, and imported it in to a fresh firefox profile in kubuntu. The icons still do not work as designed in Kubuntu. I am lost as to why it works in Win 8 but not Kubuntu when I use the same profile. Since I used a KDE distro, I have to use the firefox-kde-support and kmozzilahelper packages from the blue-shell(Kubuntu developers) Launchpad PPA. To my knowledge nothing changes in the search engine function, but I am throwing it out there as I am not sure.

I have tried copying over the searchplugins folder from windows. I have tried restoring the default search for google. I have even tried to update the favicon manually. None of the above worked.

2 REPLIES
Site Moderator

Re: Search Engine Favorite Icons Broke in Linux but Not Windows

The default search engines should be installed via the corresponding XML files in the searchplugins folder in the Firefox installation folder as base64 encoded image data.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

You can also try to remove the prefs.js file and the localstore.rdf file to see if that helps.

New User

Re: Search Engine Favorite Icons Broke in Linux but Not Windows

Thanks for the response. Sorry for the late response but things came up.

Safe Mode solved the issue. So with my browser out of safe mode, I disabled the organize search engine add on. That solved the problem, but make the search engines list a long mess. I can;t understand how this is the problem since it works fine in windows 8.