cancel
Showing results for 
Search instead for 
Did you mean: 

Private Browsing NOT working

Highlighted
New User

Private Browsing NOT working

When working on with private on I close the program then open it back up and I can go right back into my email. It should make you have to log back in again. Also I can not change the settings in the privacy tab under options. Any time I change them and hit apply. I can go right back and they are exactly the way they were before I changed them. I need some help with cause it is starting to get annoying.

3 REPLIES

Re: Private Browsing NOT working

Check the security software that is preventing you from accessing Private Browsing mode.



Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Site Moderator

Re: Private Browsing NOT working

This can be caused by cookies that are stored as part of session restore.

You can set the browser.sessionstore.privacy_level pref to 2 (never) or 1 (non-HTTPS) on the about:config page to disable saving cookies via session restore.

The browser.sessionstore.privacy_level_deferred pref is used when you do not reopen the previous session automatically via "Show my windows and tabs from last time" and uses the same values.

New User

Re: Private Browsing NOT working

I started in safe mode then closed it out. Upon restarting it again it seams to have cleared the issue. Not quite sure what it could have been but it is working again. Thanks.