cancel
Showing results for 
Search instead for 
Did you mean: 

Plugin check page says I need to update Google Earth, but the link doesn't work.

Highlighted
New User

Plugin check page says I need to update Google Earth, but the link doesn't work.

This question came up before. Pineman gave a useful link. I went there. I was told that I have the plug-in version 6.1.0.5001 installed. Isn't that the latest? If so, why doesn't Firefox know that?

1 REPLY
Site Administrator

Re: Plugin check page says I need to update Google Earth, but the link doesn't work.

Hi bobgustafson,

You might want to re-open the old thread and ask your question there as the people who were participating in the discussion won't be able to see your question.

I believe this is the one: https://support.mozilla.org/en-US/questions/925671?