cancel
Showing results for 
Search instead for 
Did you mean: 

Pictures in htm file fail to display.

SOLVED
Highlighted
New User

Pictures in htm file fail to display.

As part of a website, I have created an htm file using the Word save-as function to convert a docx file containing both text and imbedded jpg pictures. Firefox displays the text but not the pictures in the htm file. Internet Explorer displays both. I am stumped because I have several other htm files that do display as desired using Firefox.

I am using Windows 7, Word 2010, and Firefox 18.0.1. As far as I know, all are up to date.

1 ACCEPTED SOLUTION

Accepted Solutions
New User

Re: Pictures in htm file fail to display.

Thanks, but I solved the problem and obviously before you accessed the problem web page. My solution was to save=as using the "filtered" option. I do not know why this worked since I did not use this approach on several other doc to htm conversions.

8 REPLIES
Support Forum Moderator

Re: Pictures in htm file fail to display.

Did you upload the pictures too?

If so, do you have the correct path to those images on the server.
If not, that webpage may be looking for those images where they were located when you created that page - on your hard drive.

IE may be pulling those images from Temp files, if you viewed that page while it was still on your hard drive as you were developing that page.

Or, as I recall, IE will display images which are still on your PC. One reason IE isn't as secure as Firefox.

Site Moderator

Re: Pictures in htm file fail to display.

Make sure that you have disabled MS Office VML code when saving the file in Word, otherwise the images may have been saved in a way that only work in IE and that is not compatible with Firefox.

New User

Re: Pictures in htm file fail to display.

Thanks for your response. The problem also occurs when Firefox opens the htm file on my hard drive. When a Word file is saved as a htm, a folder is also created containing all of the images in the docx file. Both the folder and the htm file must be uploaded for the retrieval to work. In this case, it does not.

New User

Re: Pictures in htm file fail to display.

Thanks for your response. The problem also occurs when Firefox opens the htm file on my hard drive. When a Word file is saved as a htm, a folder is also created containing all of the images in the docx file. Both the folder and the htm file must be uploaded for the retrieval to work. In this case, it does not. I have created several htm files using this approach without difficulty. However, I am willing to give your suggestion a try. Can you provide direction to allow me to turn off the VML code?

Site Moderator

Re: Pictures in htm file fail to display.

Do you have a link to a web page where the images aren't working?

You can also check the images in the Tools > Page Info > Media page to see the actual path and check if the file is on the server.

Also make sure that the image path has forward slashes and not backslashes that Firefox shows escaped as %5C.

Note that you can only load images via a relative path if they are stored in a sub directory of the main html file when opened locally.

New User

Re: Pictures in htm file fail to display.

The website link is http://hrhfh.org/index.html. Near the bottom of this page is a word: Stories. Clicking on this word executes a link (http://hrhfh.org/Stories.htm) that is the problem page. If you explore other tabs on the website, they all utilize the htm approach and work as expected.

Support Forum Moderator

Re: Pictures in htm file fail to display.

http://hrhfh.org/Stories.htm

I am having no problem seeing the 5 images on that page.

Please reload the webpage while bypassing the cache using one of the following steps:

  • Hold down the Shift key and click the Reload button with the left mouse key.

OR

  • Press Ctrl + F5 or Ctrl + Shift + R (Windows and Linux)
  • Press Command + Shift + R (Mac)

See if this helps solve the issues you had and please report back to us!

New User

Re: Pictures in htm file fail to display.

Thanks, but I solved the problem and obviously before you accessed the problem web page. My solution was to save=as using the "filtered" option. I do not know why this worked since I did not use this approach on several other doc to htm conversions.