cancel
Showing results for 
Search instead for 
Did you mean: 

On the FAFSA web page, my updated Firefox browser is incompatible; I need this setup to operate the site: Mozilla Firefox 3.5.x and 3.6.x. Does this mean I need to downgrade? If so, how do I do that?

Highlighted
New Contributor

On the FAFSA web page, my updated Firefox browser is incompatible; I need this setup to operate the site: Mozilla Firefox 3.5.x and 3.6.x. Does this mean I need to downgrade? If so, how do I do that?

I talked to an customer service representative of the site and they repeated that I needed those specific browsers. Mine is apparently too advanced to run properly. How do I use the older browser?

1 REPLY
Regular Contributor

Re: On the FAFSA web page, my updated Firefox browser is incompatible; I need this setup to operate the site: Mozilla Firefox 3.5.x and 3.6.x. Does this mean I need to downgrade? If so, how do I do that?

You can probably use the portable version and then not have to downgrade. Smiley Happy

check out this topic for more info: https://support.mozilla.com/en-US/questions/843197