cancel
Showing results for 
Search instead for 
Did you mean: 

On Fedora-10 firefox 18.x, 19.x crash on startup with undefined NS_CycleCollectorSuspect2_P cant load xpcom

Highlighted
New Contributor

On Fedora-10 firefox 18.x, 19.x crash on startup with undefined NS_CycleCollectorSuspect2_P cant load xpcom

Under fedora-10 Linux, firefox-17.0.1 worked well. After upgrading to firefox-18.0 (and also after installing later versions of firefox) when firefox attempts to start, it crashes with the error messages:

XPCOMGlueLoad error for file /usr/local/firefox.18.0/libxpcom.so Undefined symbol NS_CycleCollectorSuspect2_P Couldn't load XPCOM

1 REPLY
Site Moderator

Re: On Fedora-10 firefox 18.x, 19.x crash on startup with undefined NS_CycleCollectorSuspect2_P cant load xpcom

Make sure that you meet the system requirements for Firefox 18+ versions.

  1. GTK+ 2.18 or higher
  2. GLib 2.22 or higher