cancel
Showing results for 
Search instead for 
Did you mean: 

Newest upgrade is not compatible with Mac10.4.11. Hate the warnings when I can't do anything about it. Suggestions?

Highlighted
New Contributor

Newest upgrade is not compatible with Mac10.4.11. Hate the warnings when I can't do anything about it. Suggestions?

I have downloaded newest version but it will not operate on eMac 10.4.11. Are there any alternatives that will provide adequate security?

1 REPLY
Support Forum Moderator

Re: Newest upgrade is not compatible with Mac10.4.11. Hate the warnings when I can't do anything about it. Suggestions?

Firefox 4 requires at least OS X 10.5 and an Intel Mac. There is a third party version of Firefox 4 that runs on OS X 10.4/10.5 and PPC Macs, for details see http://www.floodgap.com/software/tenfourfox

If you prefer, you can get the latest version of Firefox 3.6 from http://www.mozilla.com/en-US/firefox/all-older.html