cancel
Showing results for 
Search instead for 
Did you mean: 

Need upgrade that is XP 64bit compatible !!!!!!! When are you going to quit overlooking us?

SOLVED
Highlighted
New Contributor

Need upgrade that is XP 64bit compatible !!!!!!! When are you going to quit overlooking us?

Firefox keeps sending notification to "UpDate my Firefox" but because I have XP 64bit - I always check the specifications - if I don't it SCREWS up my PC ... well the update specifications DO NOT SUPPORT 64bit ... now what do I do ? But yet you keep sending me the same notification ... HELP ... I think my Firefox is 8. right now

1 ACCEPTED SOLUTION

Accepted Solutions
New Contributor

Re: Need upgrade that is XP 64bit compatible !!!!!!! When are you going to quit overlooking us?

well so far it worked ... but it has disabled my 2012 Soda for Firefox (guess ya can't have everything ... but thanks

3 REPLIES
Support Forum Moderator

Re: Need upgrade that is XP 64bit compatible !!!!!!! When are you going to quit overlooking us?

Firefox-32 bit versions works fine on Windows 64-bit.

New Contributor

Re: Need upgrade that is XP 64bit compatible !!!!!!! When are you going to quit overlooking us?

okay , will try next time it pops up ... will let you know !!!

New Contributor

Re: Need upgrade that is XP 64bit compatible !!!!!!! When are you going to quit overlooking us?

well so far it worked ... but it has disabled my 2012 Soda for Firefox (guess ya can't have everything ... but thanks