cancel
Showing results for 
Search instead for 
Did you mean: 

NEW LINK NEW TAB NOT WORKING

Highlighted
New User

NEW LINK NEW TAB NOT WORKING

Hi,

I am Having a little annoying problem the last couple of days at first i set my browser to open any link to a new tab but recently it doesnt work anymore every link i now click just changes the current page instead of opening a new tab it is no big deal i can still use my middle mouse button to open a new tab but still i would like to have my old setting back

18 REPLIES
Site Moderator

Re: NEW LINK NEW TAB NOT WORKING

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See:

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
New User

Re: NEW LINK NEW TAB NOT WORKING

Hi,

First of all thanks for the fast reply but the safe mode doesn't work either i followed your steps 1 by 1 but still no luck i also tried re-install firefox but no good everything is still the same

i did not install any new plug-ins or add-ons in a while so i have no idea whats causing the problem


J-S opening new tabs with middle mouse button works fine but the left button just changes the current tab

Site Moderator

Re: NEW LINK NEW TAB NOT WORKING

How are you opening links?

The setting in Tools > Options > Tabs: "New pages should be opened in": "a new tab/window" is for links that specify a target window to open the link.
That option allows you to divert such links to a new tab or to the current tab.
For other links use a middle-click or hold down Ctrl and left-click the link or use the right-click context menu.
Left-click a JavaScript (onclick) link to avoid getting a blank tab.

New User

Re: NEW LINK NEW TAB NOT WORKING

Uninstall the ASK toolbar from addons and problem ll be solved.

Tools>> addons >> uninstall ASK /Foxit toolbar >> Problem solved

New User

Re: NEW LINK NEW TAB NOT WORKING

Thanks! That did the trick. I just noticed the tool bar and wondered where it came from. Do you know? E

New User

Re: NEW LINK NEW TAB NOT WORKING

I had the same problem. I then uninstalled the "Ask Toolbar" in add-ons which has installed itself somehow and the problem went away. Hope this helps anyone else!

New User

Re: NEW LINK NEW TAB NOT WORKING

I have this problem as well, and tried basically everything (also all of the solutions above). Even a fresh install (didn't help). I have this issue (using the same Logitech LX3) since I switched from Firefox 3.x to 4.x and now 5.x, all on Windows 7.

Basically, the middle mouse button behavior is totally unreliable. Most of the times, it doesn't work at all. However, sometimes it does, but then it may take up many seconds (keeping the middle button pressed) until the tab finally opens... and then it often opens multi. Sometimes the tab(s) open after X seconds while the middle mouse button is still pressed, sometimes it opens after the button was released.

It seems to be a bit better in Private Browsing mode, though. Can't really be more specific: sometimes the middle mouse button opens the new tab after seconds in "using tab x, page y, link z", while it doesn't work on exactely that same page on "using tab x, page y, link z" after doing nothing for 5 minutes.

Re: NEW LINK NEW TAB NOT WORKING

Thx, working fine for me

New User

Re: NEW LINK NEW TAB NOT WORKING

There's no ASK Toolbar here. Same problem just started today. Middle button works fine for scrolling or clicking and moving the page up and down, but when I middle-click links, nothing happens.