cancel
Showing results for 
Search instead for 
Did you mean: 

My Mac G5 OS10.3.9 is to old to get the latest upgrade. No solutions offered. Ownloading version 3.6.8 gets corrupt file message. What to do?

SOLVED
Highlighted
Grand Master Contributor

My Mac G5 OS10.3.9 is to old to get the latest upgrade. No solutions offered. Ownloading version 3.6.8 gets corrupt file message. What to do?

I have a Mac G5 system 10.3.9 too old to accept latest Firefox upgrade. Tried it and get 'corrupt file' message. What do I do? My hotmail account will not now work!

This happened

Every time Firefox opened

== A new upgrade notice appeared in on launching my Hotmail.

1 ACCEPTED SOLUTION

Accepted Solutions
Support Forum Moderator

Re: My Mac G5 OS10.3.9 is to old to get the latest upgrade. No solutions offered. Ownloading version 3.6.8 gets corrupt file message. What to do?

Firefox 2.0.0.20 is the last ever release of Firefox for Mac OSX 10.3.9 and earlier versions. Another Mac 10.3.9 / Firefox 2 user said the "mobile" version of Hotmail worked for him, but didn't bother explaining any more than that. (Can't help with that myself, because I haven't used Hotmail in over ten years.)

Or, try using Safari for accessing your Hotmail account.

3 REPLIES
Support Forum Moderator

Re: My Mac G5 OS10.3.9 is to old to get the latest upgrade. No solutions offered. Ownloading version 3.6.8 gets corrupt file message. What to do?

Firefox 2.0.0.20 is the last ever release of Firefox for Mac OSX 10.3.9 and earlier versions. Another Mac 10.3.9 / Firefox 2 user said the "mobile" version of Hotmail worked for him, but didn't bother explaining any more than that. (Can't help with that myself, because I haven't used Hotmail in over ten years.)

Or, try using Safari for accessing your Hotmail account.

New Contributor

Re: My Mac G5 OS10.3.9 is to old to get the latest upgrade. No solutions offered. Ownloading version 3.6.8 gets corrupt file message. What to do?

Sorry - Safari seems to be even worse with the new hotmail.

Still it would be nice for someone to tell us why Firefox is no longer supporting OSX 10.3.9 as OSX 10.4 and later do not support some of the old hardware. Is it something missing from OSX 10.3.9, is it a problem of yet another cpu type - or is there a problem in supporting all the language variants?

Site Moderator

Re: My Mac G5 OS10.3.9 is to old to get the latest upgrade. No solutions offered. Ownloading version 3.6.8 gets corrupt file message. What to do?

The main cause if the Cairo library used by Firefox that no longer supports OS X 10.3 versions.
See http://en.wikipedia.org/wiki/Cairo_(graphics)

Firefox 4 will also drop support for Mac OS X 10.4

http://groups.google.com/group/mozilla.dev.planning/browse_thread/thread/7d3a647586bab993 Dropping Mac OS X 10.4 support in Gecko 1.9.3