cancel
Showing results for 
Search instead for 
Did you mean: 

MNSure, Minnesota's version of Obamacare, requires Firefox 24. Are there security issues in 24 which could compromise user information? Thanks.

Highlighted
New Contributor

MNSure, Minnesota's version of Obamacare, requires Firefox 24. Are there security issues in 24 which could compromise user information? Thanks.

MNSure has issues with any other browser versions that Chrome 30, Firefox 24, Safari 6.0.5 and IE 9. I'm concerned that security issues may allow compromise of sensitive user information.

2 REPLIES
Site Moderator

Re: MNSure, Minnesota's version of Obamacare, requires Firefox 24. Are there security issues in 24 which could compromise user information? Thanks.

hello KyleFairchild, do you have any issues accessing the page with firefox 25? maybe their information of supported browsers is just a bit outdated...

New Contributor

Re: MNSure, Minnesota's version of Obamacare, requires Firefox 24. Are there security issues in 24 which could compromise user information? Thanks.

Hi Phillip. Thanks for the response. MNSure thinks that most of the problems are with unsupported browser versions.

From a 15 Nov notice… In the meantime, if you have received the broker and agency administrator account setup emails and would like to try to create an account now, it is important that you use an internet browser that performs well on the MNsure site. The preferred browsers are: Firefox 17- 22 & 24 (download: Firefox) Google Chrome 30 (download: Google Chrome) Internet Explorer (IE) 9 Safari 6.0.5 on an Apple Please note that browser issues may only appear after you have successfully navigated several screens, so it is best to use one of the preferred browsers from the beginning of the process. In fact, if you begin the account creation process in a non-preferred browser, you may not be able to complete the process without additional help from our contact center, even if you later switch to a preferred browser.