cancel
Showing results for 
Search instead for 
Did you mean: 

Java plugin doesn't install- JRE 1.7 u10 on Firefox 18.0.1

SOLVED
Highlighted
New User

Java plugin doesn't install- JRE 1.7 u10 on Firefox 18.0.1

I've have severe problems because Firefox 18.0.1 can;t install the plugin and I can access some websites that I used frequently. I do the plugin install and it does not installed, do manually does not install. I do not know what to do. Everything was fine before I installed the 18.0.1

Where do I found and older version of firefox so I can continue with my web-life

1 ACCEPTED SOLUTION

Accepted Solutions
New User

Re: Java plugin doesn't install- JRE 1.7 u10 on Firefox 18.0.1

By the way I am running Windows 7 and not XP

10 REPLIES
New User

Re: Java plugin doesn't install- JRE 1.7 u10 on Firefox 18.0.1

I am having this problem as well. What is the fix?

Site Moderator

Re: Java plugin doesn't install- JRE 1.7 u10 on Firefox 18.0.1

Try to install the latest Java 7 Update 11 version.

See:

New User

Re: Java plugin doesn't install- JRE 1.7 u10 on Firefox 18.0.1

I have done that numerous times. Even uninstall Java and Firefox to get a fresh start with both. This did not fix the problem.

But thank you!

New User

Re: Java plugin doesn't install- JRE 1.7 u10 on Firefox 18.0.1

I've just done that, and it did not work. thanks

New User

Re: Java plugin doesn't install- JRE 1.7 u10 on Firefox 18.0.1

I did add 3 strings in the registry of XP32:

[HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@java.com/JavaPlugin,version=10.11.2] "Description"="Oracle® Next Generation Java™ Plug-In" "GeckoVersion"="1.9" "Path"="C:\\Program Files\\Java\\jre7\\bin\\plugin2\\npjp2.dll" "ProductName"="Oracle® Java™ Plug-In" "Vendor"="Oracle Corp." "Version"="1.7.0_11"

[HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@java.com/JavaPlugin,version=10.11.2\MimeTypes]

[HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@java.com/JavaPlugin,version=10.11.2\MimeTypes\application/x-java-applet] "Description"="Java™ Applet"

When I opened the window the red object in the left top corner showed up, so I click on Allowed the plugin to be installed for this site only and it works. No problem anymore.

Chappy07

New User

Re: Java plugin doesn't install- JRE 1.7 u10 on Firefox 18.0.1

I did add 3 strings in the registry of XP32:

[HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@java.com/JavaPlugin,version=10.11.2] "Description"="Oracle® Next Generation Java™ Plug-In" "GeckoVersion"="1.9" "Path"="C:\\Program Files\\Java\\jre7\\bin\\plugin2\\npjp2.dll" "ProductName"="Oracle® Java™ Plug-In" "Vendor"="Oracle Corp." "Version"="1.7.0_11"

[HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@java.com/JavaPlugin,version=10.11.2\MimeTypes]

[HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@java.com/JavaPlugin,version=10.11.2\MimeTypes\application/x-java-applet] "Description"="Java™ Applet"

When I opened the window the red object in the left top corner showed up, so I click on Allowed the plugin to be installed for this site only and it works. No problem anymore.

Chappy08

2013-01-23-13-03-40-7e823b.png
New User

Re: Java plugin doesn't install- JRE 1.7 u10 on Firefox 18.0.1

I have THE problem. Before I edit the registry I have a question.

When I check add-on manager it shows: "Java Deployment Toolkit 7.0.110.21 10.11.2.21" It also appears in the registry. I have tried to install the Java plug-in with this both enabled and disabled with the same result. It fails.

Do I need to remove the Development Toolkit, and if so how?

New User

Re: Java plugin doesn't install- JRE 1.7 u10 on Firefox 18.0.1

By the way I am running Windows 7 and not XP

New User

Re: Java plugin doesn't install- JRE 1.7 u10 on Firefox 18.0.1

IT DOES work for windows 7 ,, as a matter of fact, the answer is for windowes 7 users see http://kb.mozillazine.org/Java#Windows_installation_issues