cancel
Showing results for 
Search instead for 
Did you mean: 

Java console is incompatible with firefox 6.0

SOLVED
Highlighted
New Contributor

Java console is incompatible with firefox 6.0

Just upgraded to FF 6.0 (or is that 4.2? :/), and got this message ""Java console is incompatible with Firefox 6.0". At first I thought it was because I was on Java 6.26, but after upgrading to 7 the problem is still there. A fairly glaring bug after so many BETAs...

1 ACCEPTED SOLUTION

Accepted Solutions
Expert Contributor

Re: Java console is incompatible with firefox 6.0

Unless you are a Java programmer with a specific need for the Java Console add-on, you can safely leave this add-on disabled and it should have no effect on your web browsing.

If you need to re-enable it, see this page for instructions: Re-enable add-ons that were disabled when updating Firefox

21 REPLIES
Expert Contributor

Re: Java console is incompatible with firefox 6.0

Unless you are a Java programmer with a specific need for the Java Console add-on, you can safely leave this add-on disabled and it should have no effect on your web browsing.

If you need to re-enable it, see this page for instructions: Re-enable add-ons that were disabled when updating Firefox

New Contributor

Re: Java console is incompatible with firefox 6.0

Ah - yes, I wondered if that might be the case. So Java itself will operate normally without the need for the console?

Expert Contributor

Re: Java console is incompatible with firefox 6.0

Yes, web pages that use Java will still work without the Java Console add-on.

New Contributor

Re: Java console is incompatible with firefox 6.0

Firefox should have warned of this add-on incompatibility before download. I go to the java test page and it says java is not working. http://www.java.com/en/download/testjava.jsp thanks. were is the link to reinstall FF5. I knew I should have waited a few more months to install FF6

New Contributor

Re: Java console is incompatible with firefox 6.0

That's annoying for you. Smiley Sad Have you made sure that all old versions of Java are uninstalled?

And did you remove the old Java leftover entries in the Registry?

And did you make sure that all the old Java files were gone from the Firefox folder on the hard drive?

And did you make sure that the Java console entry was gone from the Firefox registry entry?

And did you delete all the leftover Java folders from the various places on the hard drive?

I've found over the years that Java has been pretty hopeless at cleaning up after itself (I use Revo Uninstaller + manual "hunt & destroy" methods - although one has to be careful with both), and usually requires some post-uninstall TLC. Hopefully the new 7 series of Java will be better.

New Contributor

Re: Java console is incompatible with firefox 6.0

Not sure if this issue applies to my issue or not, but I just tried going to the Java page linked in this thread and after check with the version check button on said page, it showed update is Java 6 - 26. And Java console 6.0.11 to 6.0.26 is Disabled. But when I try to watch a video on Youtube, the plying Video Blinks out to a white space where the video should be, when I scroll the page up a bit the video reappears, but yet I can hear the audio of the video. Also on that Java page it states to update Java to latest version before updating Firefox to latest version.

New Contributor

Re: Java console is incompatible with firefox 6.0

Yes, my reply to 8Evo applies. You'll have to do a "rigorous" uninstall of Java and it's leftovers, then install the new Java 7 (technically, 1.7). If you're not comfortable hunting down files & registry entries, it's best to find someone who is, as there is some potential for being a bit zealous in "the hunt". Smiley Happy It's taken me a year of working on different computers to get down a routine for fully, properly removing Java and old versions thereof - which would entail more writing of instructions than I have time for at the moment: sorry. Smiley Happy

New Contributor

Re: Java console is incompatible with firefox 6.0

Is this the Version of Java your referencing here at this link http://www.java.com/en/download/faq/java7.xml

I'm pretty sure I got all of Java 6 26 deleted, I also ran Ccleaner a few times on the reg and system, I looked in Firefox folder and saw no Java reference, what does show up is what apple Itunes & quicktime is reference to Java, at least that is how seems. But I just wanted to make sure I'm downloading the correct Java 7 file.

Support Forum Moderator

Re: Java console is incompatible with firefox 6.0

I have never seen a YouTube video that needed Java to run, but rather use Adobe Flash.