cancel
Showing results for 
Search instead for 
Did you mean: 

Is Firefox 3.x still available for Linux?

SOLVED
Highlighted
New User

Is Firefox 3.x still available for Linux?

Bank of America says that their ShopSafe website requires MSIE or Firefox 3.x to access the site. I'm wondering if I can download Firefox 3.x for Linux anywhere that you know of.

   What does it take to get a huge corporation like Bank of America to modernize anyway?

Thanks for all the information. I think I have enough to get by until I can get my Windows computer fixed so I can use MSIE for this site (only). I'm always amazed at the informed people who volunteer their help for questions like this.

I thought Mozilla or Firefox had a way to mark a question as solved. I guess not. Anyway consider this question solved.

1 ACCEPTED SOLUTION

Accepted Solutions
Site Moderator

Re: Is Firefox 3.x still available for Linux?

i think it borders on negligence for a bank (which should have an interest in secure communications) to recommend such outdated software with known security vulnerabilities - https://www.mozilla.org/security/known-vulnerabilities/firefox.html

maybe they just didn't update the description on their site for a long time. have you actually tried if it is working with newer firefox versions nevertheless? if the site is literally preventing you to login because you use newer versions, you could also try if spoofing your useragent back to version 3.6 makes the site stop complaining: Workaround for broken websites

4 REPLIES
Site Moderator

Re: Is Firefox 3.x still available for Linux?

i think it borders on negligence for a bank (which should have an interest in secure communications) to recommend such outdated software with known security vulnerabilities - https://www.mozilla.org/security/known-vulnerabilities/firefox.html

maybe they just didn't update the description on their site for a long time. have you actually tried if it is working with newer firefox versions nevertheless? if the site is literally preventing you to login because you use newer versions, you could also try if spoofing your useragent back to version 3.6 makes the site stop complaining: Workaround for broken websites

Site Moderator

Re: Is Firefox 3.x still available for Linux?

Which 3.x as there was 3.0.19, 3.5.19 and the bit more recent 3.6.28 (released March 13th, 2012) and all are end of life and insecure.

You may be better off trying to make 18.0.2 have the useragent of of the older versions to fool the website when ever you use it.

Site Moderator

Re: Is Firefox 3.x still available for Linux?

It is more likely that they have an outdated page with the system requirements and haven't updated it for years, so you just need to try to see if it works with current Firefox versions.

Do you have a link to a page that shows this message that doesn't require authentication (sign on)?

New User

Re: Is Firefox 3.x still available for Linux?

I believe that ShopSafe is down for some reason -- maybe related to the on-going Java security concerns. It is down for me in both Firefox & MSIE - just opens a blank browser window. And Firefox just updated to 19.0 - but maybe something is going on there -- when I mouse over the Copernicus Google Doodle in Firefox, the id pop-up is blank too. And the Java plug-ins are enabled.

W.R.T. the mininum requirements -- double edged sword. How many people keep their software up to date, even on a monthly basis? If Firefox updates, as it did today for me, would I have been irate if I held off an update because something was urgent, and was then blocked by the website? Personal security, is, as always, a personal responsibility. Let me play the devil's advocate: If using MSIE 5 only endangers your own data, should the rest of us get all hot and bothered that BOA has that as the threshold? (In thinking about this, let us not get wrapped up in the social & societial cost of a careless person to the rest of us - because yes, in some sense if you call the cops, my taxes go up.)