cancel
Showing results for 
Search instead for 
Did you mean: 

Is Firefox 16.0.1 compatible with Kaspersky Safe Money , Kaspersky Virtual Keyboard, and Kaspersky URL Advisor?

Highlighted
New User

Is Firefox 16.0.1 compatible with Kaspersky Safe Money , Kaspersky Virtual Keyboard, and Kaspersky URL Advisor?

I'm currently using Firefox 15.0.1 and have installed Kaspersky Internet Security 2013. Firefox keeps telling me that I have an update to 16.0.1; however, It does NOT have compability for Kaspersky Safe Money, Kaspersky Virtual Keyboard, and Kaspersky URL Advisor. I would like to update to Firefox 16.0.1, but I don't want to loose these Kaspersky add ons (or whatever they're called). Please help.

14 REPLIES
Mozilla Support Contributor

Re: Is Firefox 16.0.1 compatible with Kaspersky Safe Money , Kaspersky Virtual Keyboard, and Kaspersky URL Advisor?

Version 2012 now supports Firefox hotfix K, In 2013 an updated version of the add-ons to my knowledge for the next hotfix C is planned. PURE it will probably take some time, because today, the add-ons to Firefox matched with Hotfix D

New User

Re: Is Firefox 16.0.1 compatible with Kaspersky Safe Money , Kaspersky Virtual Keyboard, and Kaspersky URL Advisor?

This is my concern too.

New User

Re: Is Firefox 16.0.1 compatible with Kaspersky Safe Money , Kaspersky Virtual Keyboard, and Kaspersky URL Advisor?

Mine also. I will not upgrade until the Kaspersky extensions are supported and I'm considering just switching to Chrome.

Site Moderator

Re: Is Firefox 16.0.1 compatible with Kaspersky Safe Money , Kaspersky Virtual Keyboard, and Kaspersky URL Advisor?

a number of highly critical vulnerabilities have been fixed since firefox 15 - so you'll probably be less secure on the web when sticking with an old version. mozilla is not responsible for the compatibility of third-party addons, so please contact kaspersky's support to find out when there's an update available...

Mozilla Support Contributor

Re: Is Firefox 16.0.1 compatible with Kaspersky Safe Money , Kaspersky Virtual Keyboard, and Kaspersky URL Advisor?

One more thing is protection doesnot depend on Firefox addon, you are always protected with heuristic engine, and Kaspersky scan traffic every second to keep you protect, addon are just shortcut to run virtual keyboard, etc... You are never less secure if your addon is disable or not installed, if your Antivirus activate with commercial license, and they are updated, if your antivirus lighted green and saying you are secured then you are safe, but downgrading to an old version may compromise your security..

Site Moderator

Re: Is Firefox 16.0.1 compatible with Kaspersky Safe Money , Kaspersky Virtual Keyboard, and Kaspersky URL Advisor?

It is Kaspersky that supports Firefox updates and not the job of Mozilla to make Firefox compatible with the thousand of extensions out there, more so ones not even hosted at addons.mozilla.org

Kaspersky has always been a bit behind as 16.0 was released on Oct 9.

Re: Is Firefox 16.0.1 compatible with Kaspersky Safe Money , Kaspersky Virtual Keyboard, and Kaspersky URL Advisor?

i called kaspersky support , they told me that its mozillas problem they have to solve this , because they do not supprt kaspersky new version, so what should we do nw?

New User

Re: Is Firefox 16.0.1 compatible with Kaspersky Safe Money , Kaspersky Virtual Keyboard, and Kaspersky URL Advisor?

My immediate reaction to use a different browser but frankly I don't like the options. I don't like MSIE and when I launch Chrome there are 10 or more processes running on my machine, all called Chrome.exe. I really don't like that.

Site Moderator

Re: Is Firefox 16.0.1 compatible with Kaspersky Safe Money , Kaspersky Virtual Keyboard, and Kaspersky URL Advisor?

mzaman.real, Mozilla has never specifically supported kaspersky with any Firefox version new or old. Unless it can be proven that a new version has a bug or regression that is making it difficult for kaspersky to get their stuff working which has yet to ever happen.

The kaspersky support tech may not have cared to help you or was trying direct blame at Mozilla.

In thread, kaspersky email support responses has them implying that Mozilla still has not made Firefox 16.0 compatible, when it is really the other way. http://forum.kaspersky.com/index.php?showtopic=246187

Even Norton got their act together and went from being rather slow on updating to having a Norton update within a day or two at latest when a new major Firefox version is released ever since Firefox 4.0.

With most normal Extensions ever since Firefox 10.0 the extensions compatibility has not been a issue with the exception of those that are binary or version specific like those that are supplied by antivirus like the ones from Kaspersky and Norton for example.