cancel
Showing results for 
Search instead for 
Did you mean: 

Installed Norton - get msg: This version of Firefox is not supported by Norton Confidential. Phishing Protectn requires Firefox 1.5 or later. can find newer ver

SOLVED
Highlighted
New Contributor

Installed Norton - get msg: This version of Firefox is not supported by Norton Confidential. Phishing Protectn requires Firefox 1.5 or later. can find newer ver

Have MacPro 10.6.8 I have tried what your website says is the latest Firefox version and when I go to install it says it is an older version that what if have already in stalled. And Norton Confidential says it cannot protect you while you use this version of fire fox. Phishing Protection requires Fire foz 1.5 or later. I just want to download the version that works with Norton.

1 ACCEPTED SOLUTION

Accepted Solutions
Site Moderator

Re: Installed Norton - get msg: This version of Firefox is not supported by Norton Confidential. Phishing Protectn requires Firefox 1.5 or later. can find newer ver

Norton confidential is a old product that Norton killed off, which explains the out dated messages about Firefox 1.5. It has been replaced by Norton Identity Safe. https://identitysafe.norton.com/

4 REPLIES
Site Moderator

Re: Installed Norton - get msg: This version of Firefox is not supported by Norton Confidential. Phishing Protectn requires Firefox 1.5 or later. can find newer ver

Honestly, Norton's tools are junk, you don't gain any additional security by using them and they can cause alot of problems, you are better off just uninstalling them.

If you do want to keep using norton, https://community.norton.com/t5/Product-Update-Announcements/Firefox-26-Support-for-Norton-Toolbar/b... might help

New Contributor

Re: Installed Norton - get msg: This version of Firefox is not supported by Norton Confidential. Phishing Protectn requires Firefox 1.5 or later. can find newer ver

I just want security for my Mac pro. When you say additional security are you saying I already have it?

Site Moderator

Re: Installed Norton - get msg: This version of Firefox is not supported by Norton Confidential. Phishing Protectn requires Firefox 1.5 or later. can find newer ver

I'm saying that the security in Norton's toolbar (the part complaining that Firefox and it aren't compatible) won't provide any security that Firefox doesn't already have. Norton's actual anti-virus program runs independent of the browser you use and so isn't part of this. You should remove the norton Firefox extensions, and leave the norton anti-virus component

Site Moderator

Re: Installed Norton - get msg: This version of Firefox is not supported by Norton Confidential. Phishing Protectn requires Firefox 1.5 or later. can find newer ver

Norton confidential is a old product that Norton killed off, which explains the out dated messages about Firefox 1.5. It has been replaced by Norton Identity Safe. https://identitysafe.norton.com/