cancel
Showing results for 
Search instead for 
Did you mean: 

Image in an <a> element doesn't link in a <div> element set

Highlighted
New User

Image in an <a> element doesn't link in a <div> element set

The following code works in other browsers but not FF, and it stopped working in FF probably around version 14 or so (when I first noticed). \ = angle bracket

<div style="float:left;width:350px;">
<a href="index.html"><img src="red.jpg" alt="red" width="349" height="100" align="left" border="0"></a>
</div>

<div style="position:relative;top:20px;">
<h2 align="center">Text Moved to Right<br>
to test anchor link</h2>
</div>

If you mouse over the red box image area, the anchor only works at the top and bottom margin of the image. If you remove the second <div>, the anchor element works ok. This works with other browsers I've tried, just not with FF.

I tried setting display:block for the <img> element to no avail. Maybe something changed in the browser's main rendering engine that's now causing this.

Thanks.

2 REPLIES
New User

Re: Image in an <a> element doesn't link in a <div> element set

Fixed the code in the previous post.

Site Moderator

Re: Image in an <a> element doesn't link in a <div> element set

You may need a clear div because you have floating content.

A good place to ask advice about web development is at the MozillaZine "Web Development/Standards Evangelism" forum.

The helpers at that forum are more knowledgeable about web development issues.
You need to register at the MozillaZine forum site in order to post at that forum.