cancel
Showing results for 
Search instead for 
Did you mean: 

I upgraded to 6.02 and still get this message from Gmail: "You are using an old version of Firefox which Gmail no longer supports. Some features may not work correctly. Upgrade to new version."

Highlighted
New User

I upgraded to 6.02 and still get this message from Gmail: "You are using an old version of Firefox which Gmail no longer supports. Some features may not work correctly. Upgrade to new version."

When I opened Gmail in my Firefox browser, I got a message I've never seen, before: "You are using an old version of Firefox which Gmail no longer supports. Some features may not work correctly. Upgrade to new version." I clicked on upgrade to a new version and was taken to the Mozilla site, where I downloaded the latest version of Firefox... then, when I restarted my computer, Gmail still gives me the same message!! What's going on?

4 REPLIES
Site Moderator

Re: I upgraded to 6.02 and still get this message from Gmail: "You are using an old version of Firefox which Gmail no longer supports. Some features may not work correctly. Upgrade to new version."

You posted with a Firefox 3.5.5. user agent:

  • Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)

See:

New User

Re: I upgraded to 6.02 and still get this message from Gmail: "You are using an old version of Firefox which Gmail no longer supports. Some features may not work correctly. Upgrade to new version."

Had the same problem, reset your user agent, solved it, here's the how to: https://support.mozilla.com/en-US/kb/Websites+or+add-ons+incorrectly+report+incompatible+browser

New User

Re: I upgraded to 6.02 and still get this message from Gmail: "You are using an old version of Firefox which Gmail no longer supports. Some features may not work correctly. Upgrade to new version."

I have another problem - Firefox no longer supports my Mac OSX so I can't download the latest Firefox. At least not without changing my operating system. Maybe that will be bad luck for Gmail...

Site Moderator

Re: I upgraded to 6.02 and still get this message from Gmail: "You are using an old version of Firefox which Gmail no longer supports. Some features may not work correctly. Upgrade to new version."

Firefox 4 and later require at least OS X 10.5 and a Mac with an Intel processor.

For an unofficial Firefox ESR 10.0.4 compatible version (TenFourFox) that runs on PowerPC Macs with OS X 10.4.11 or OS X 10.5.8 you can look at:

Be aware that TenFourFox doesn't support plugins.