cancel
Showing results for 
Search instead for 
Did you mean: 

I updated to Firefox 4 and it will not work so I can not get on line and it replaced the old firefox so I also lost all my bookmarks. I need them back. How do I get them?

Highlighted
New Contributor

I updated to Firefox 4 and it will not work so I can not get on line and it replaced the old firefox so I also lost all my bookmarks. I need them back. How do I get them?

I have a Mc g5 with the 10.4.11 operating system. Your site is my home page and it kept bugging me to update to the firefox 4. So I did now when I try to get on it tells me that that "I can not open this application because it is not supported on this system". It replaced the old firefox that I had so I can not open that. I have no way to get to my book marks and I need them. Let me know how to get back to my old firefox and book marks.

Tags (2)
2 REPLIES
Site Moderator

Re: I updated to Firefox 4 and it will not work so I can not get on line and it replaced the old firefox so I also lost all my bookmarks. I need them back. How do I get them?

Firefox 4 requires at least OS X 10.5 and an Intel Mac.

For an unofficial Firefox 4 compatible version (TenFourFox) that runs on PowerPC Macs with OS X 10.4.11 or OS X 10.5.8 you can look at:

Firefox 3.6.x (Mac OS X 10.4 and later) can be found here:


New Contributor

Re: I updated to Firefox 4 and it will not work so I can not get on line and it replaced the old firefox so I also lost all my bookmarks. I need them back. How do I get them?

I've got it now, but I was not happy with the surprise, or the initial fear i had when I thought it wouldn't be simple enough to get it back.