cancel
Showing results for 
Search instead for 
Did you mean: 

I need to install 3.6 Firefox to work with SiteBuilder, how can I get a Download for MAC?

SOLVED
Highlighted
New User

I need to install 3.6 Firefox to work with SiteBuilder, how can I get a Download for MAC?

Please send me a link to download the MAC 3.6 version of Firefox. Register.com told me it is the only way to solve a compatibility issue with their ancient SiteBuilder software. I'm stuck until I get it. Thank you

1 ACCEPTED SOLUTION

Accepted Solutions
Senior User

Re: I need to install 3.6 Firefox to work with SiteBuilder, how can I get a Download for MAC?

Sorry this is the correct link to download firefox 3.6 for mac http://ftp://ftp.mozilla.org/pub/firefox/releases/3.6/mac/

4 REPLIES
Senior User

Re: I need to install 3.6 Firefox to work with SiteBuilder, how can I get a Download for MAC?

Here Mozilla releases you can download firefox 3.6. The setup is in your language folder. Before you install this version i must tell you that is dangerous to install a old version of firefox for your security when you surf the net.

Site Moderator

Re: I need to install 3.6 Firefox to work with SiteBuilder, how can I get a Download for MAC?

See this article about how to install multiple versions on Mac OS X:

New User

Re: I need to install 3.6 Firefox to work with SiteBuilder, how can I get a Download for MAC?

I current run 24, I don't have 3.6. I need 3.6

Senior User

Re: I need to install 3.6 Firefox to work with SiteBuilder, how can I get a Download for MAC?

Sorry this is the correct link to download firefox 3.6 for mac http://ftp://ftp.mozilla.org/pub/firefox/releases/3.6/mac/