cancel
Showing results for 
Search instead for 
Did you mean: 

I need to have FireFox 3.6 and (any) modern version installed at the same time. How?

Highlighted
New Contributor

I need to have FireFox 3.6 and (any) modern version installed at the same time. How?

Hi. As per the topic. The nature of my job (test analyst) requires me to have both the old 3.6 and any of the modern versions of FF installed on my PC. Is this possible at all and how can I do it? Many thanks.

2 REPLIES
New Contributor

Re: I need to have FireFox 3.6 and (any) modern version installed at the same time. How?

Hey rootsrat and welcome to the Mozilla Forums. Smiley Happy

Please check out this link and let me know if it works:

https://support.mozilla.org/en-US/questions/797010#answer-151667

Site Moderator

Re: I need to have FireFox 3.6 and (any) modern version installed at the same time. How?

You can install the portable Firefox 3.6.x version to access websites that do not work with Firefox 5+.